Rob Crittenden wrote:
> Dmitri Pal wrote:
>> Rob Crittenden wrote:
>>> Dmitri Pal wrote:
>>>> Hello,
>>>>
>>>> Here are some issues that I came across during my testing of the
>>>> latest
>>>> IPA version on Friday.
>>>> Please take a look and file tickets as appropriate.
>>>>
>>>> 1) Can't bail out from the install
>>>> Start IPA install without any command line parameters. It any
>>>> prompt try
>>>> to stop installation by pressing Ctrl+C.
>>>> You are still at the prompt and there is no way to abort installation.
>>>> This can be an ER.
>>>
>>> Was this in a password prompt? I'm thinking that python 2.7 changed
>>> their handling.
>> Yes. But I think not only. The first prompt is the prompt for domain and
>> you can't break from it either.
>
> It works for me. What distro are you using?

F14. I will retest.

>
>>
>>
>>>
>>>>
>>>> 2) For the unattended install with -U the -u is listed as required
>>>> option
>>>>          -u, --user=DS_USER
>>>>                 The user that the Directory Server will run as
>>>> Why it is a required if the interactive install never asks for it.
>>>> IMO a
>>>> bug.
>>>
>>> It seemed an unnecessary question to prompt for in the UI so we
>>> removed it. It should be optional in non-interactive.
>> Please file a ticket.
>
> done
>
>>
>>>
>>>>
>>>> 3) When adding service in UI via popup it does not automatically
>>>> append
>>>> realm to the host when it creates a service pricipal.
>>>> IMO a bug.
>>>
>>> The framework will add the realm automatically if it is not provided.
>>> Or are you actually seeing a service created with no realm?
>> Created with no realm.
>
> Can you do an ldapsearch to confirm this? I never include the realm
> when I add services, it gets automatically added.
I will retry.

What about the rest below?


>
>>
>>>
>>>> 4) The service status is all messed up and unclear. After just being
>>>> added it should be in "not provisioned"
>>>> state but this is not what you see. You see as if it is already
>>>> provisioned.
>>>> When the service screen is shown it blinks showing a lot of different
>>>> buttons and statuses before it settles down on the following UI
>>>>
>>>> Please retry. May be it is already addressed with latest fixes.
>>>>
>>>>
>>>> 5) The items in the action panel are now black
>>>>
>>>> The links in the action panel that you are supposed to click are now
>>>> black which is not intuitive since they are clickable links.
>>>>
>>>> 6) [dpal@lenovo ~]$ ipa host-add foobar.home --ip-address=1.1.1.1
>>>> --no-reverse
>>>> ipa: ERROR: The host was added but the DNS update failed with:
>>>> 1.1.1.in-addr.arpa: DNS zone not found
>>>>
>>>> Should not fail since --no-reverse is specified. I checked. If the
>>>> zone
>>>> is there it is added automatically.
>>>>
>>>
>>
>>
>
> _______________________________________________
> Freeipa-devel mailing list
> Freeipa-devel@redhat.com
> https://www.redhat.com/mailman/listinfo/freeipa-devel
>
>


-- 
Thank you,
Dmitri Pal

Sr. Engineering Manager IPA project,
Red Hat Inc.


-------------------------------
Looking to carve out IT costs?
www.redhat.com/carveoutcosts/

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to