Jakub Hrozek wrote:
On Mon, Jan 31, 2011 at 05:52:08PM -0500, Simo Sorce wrote:
On Mon, 31 Jan 2011 22:44:43 +0100
Jakub Hrozek <jhro...@redhat.com> wrote:

https://fedorahosted.org/freeipa/ticket/881

We've run into a chicken-and-egg problem during installation. If the
hostname of the IPA server is not resolvable with DNS during
installation, we'd add it as a NS server for a zone in both the SOA
entry and a NS record -- but no records from the new zone are
resolvable until Bind is restarted, including the new A/AAAA records
for the nameserver.

I tried restarting the named service during Bind instance creation but
that didn't help..not exactly sure why. Anyway, attached is a patch
that forces the NS record creation.

Please note that the --force flag is available via XML-RPC only, it is
completely hidden from the user otherwise.
Minor issue but requires NACK.

You changed the add_zone() signature to always require some parameters,
but did not update it in ipa-replica-prepare

Simo.

Good catch, thank you!

Attached is a new patch. I also found out that I don't have to require
all the parameters as some (such as admin email) have nice defaults in
the DNS plugin.

------------------------------------------------------------------------
Well. I just opened a bug for this exact issue.

https://bugzilla.redhat.com/show_bug.cgi?id=674200

I wouldn't have if I had seen this email thread first.

I'm sorry if I'm creating more work unnecessarily.

I'll quietly ignore this issue, as it's already being worked on.

Michael-


_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to