On 3.10.2011 09:54, Martin Kosek wrote:
On Sat, 2011-10-01 at 19:45 +0200, Jan Cholasta wrote:
On 29.9.2011 12:01, Martin Kosek wrote:
When group/user is migrated, the attribute used for RDN may be
multivalued. Make sure that we pick the value used in the RDN
which should be the unique one and not just the first one.

https://fedorahosted.org/freeipa/ticket/1892


Every time you do "import *", god kills a kitten. Also, it pollutes the
module namespace with unnecessary symbols and decreases code readability.

World is not just black and white. In this case I think its OK since
ipalib/dn.py has a nice maintained __all__ list with all 3 DN related
classes. Thus. I see no namespace pollution.

IMO it still somewhat decreases code readability. But, whatever, it's no showstopper.



I'm a bit puzzled why do you do this:
+                    try:
+                        pkey = dn[ldap_obj.primary_key.name].lower()
+                    except KeyError:
+                        failed[ldap_obj_name][str(dn)] =
unicode(_rdn_err_msg)
+                        continue

and not just this:
+                    pkey = ava.value.lower()

Good point. Updated patch attached.

Martin


Besides that, the issue seems to be fixed.

Honza



ACK.

Honza

--
Jan Cholasta

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to