Rob Crittenden wrote:
Update the minimum selinux-policy for F-17. This will enable
ipa_memcached to run in Enforcing mode. Still waiting on this to be
backported to at least F-16.

You have to manually enable the boolean.

rob


F-16 package is in updates-testing, patch updated.

rob
>From bd4e126150e0338541e2f476678772752c7b3037 Mon Sep 17 00:00:00 2001
From: Rob Crittenden <rcrit...@redhat.com>
Date: Tue, 28 Feb 2012 05:25:15 -0500
Subject: [PATCH] Set minimum version of selinux-policy to pick up memcached
 fix

This package version adds a boolean, httpd_manage_ipa, that enables
the ipa_memcached service to work.

https://fedorahosted.org/freeipa/ticket/2433
---
 freeipa.spec.in |   10 +++++++++-
 1 files changed, 9 insertions(+), 1 deletions(-)

diff --git a/freeipa.spec.in b/freeipa.spec.in
index 9421bd2..e5089ca 100644
--- a/freeipa.spec.in
+++ b/freeipa.spec.in
@@ -113,11 +113,19 @@ Requires: systemd-units >= 36-3
 Requires(pre): systemd-units
 Requires(post): systemd-units
 %endif
-%if 0%{?fedora} >= 15
+%if 0%{?fedora} >= 17
+Requires: selinux-policy >= 3.10.0-82
+%else
+%if 0%{?fedora} == 16
+Requires: selinux-policy >= 3.10.0-78
+%else
+%if 0%{?fedora} == 15
 Requires: selinux-policy >= 3.9.16-18
 %else
 Requires: selinux-policy >= 3.9.7-27
 %endif
+%endif
+%endif
 Requires(post): selinux-policy-base
 Requires: slapi-nis >= 0.21
 %if 0%{?fedora} >= 16
-- 
1.7.6

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to