On Fri, 20 Apr 2012, John Dennis wrote:
On 04/20/2012 01:35 PM, Alexander Bokovoy wrote:
Hi John,

On Fri, 20 Apr 2012, John Dennis wrote:
We're supposed to be working on master now, not 2.2. But master has
dependencies on samba4. Those dependencies can only be resolved on
F17, an unreleased platform.

I think it's reasonable for IPA developers to work on the current
Fedora release (F16) and not have to resort to trying to develop
inside a vm or run builds inside of mock, etc.

Even the most basic developer task such as running make-lint won't
work because it requires you run make to populate the generated
files. But you can't run make because the configure step fails, it
fails because it can't satisfy the samba4 dependencies. The samba4
dependencies can't be satisfied on F16 (I know, I tried).
Please try http://koji.fedoraproject.org/koji/taskinfo?taskID=4009116

We are trying to make sure samba4 development packages and libraries are
installable in parallel to samba3 libraries so that other F16 components
would continue working. Unfortunately, it is a bit more complicated than
needed due to versioning symbols in multiple libraries. The update above
should solve the issues.

FWIW, I tried to build samba4-4.0.0-42alpha18.fc17.src.rpm in mock on
my local F16 machine and it fails because it depends on libldb 1.1.4
which is only in F17, and so on and so on.

So how are others working on master and how are you getting around
this problem?
Updated F16 build is
http://koji.fedoraproject.org/koji/taskinfo?taskID=4009116

Did you notice the koji builds you referenced failed to build? This is why I tried to do a local mock build of the srpm, which also failed due to libldb dependencies. Which is what caused me to write the original mail :-)
:)

It failed to build due to koji issues, not the build issues.

We had also incompatible libldb in F16/F15 that prevented us going to
alpha18 instead of alpha16 in those distributions.

I hope Andreas (CC:) will be able to look at the issue soon...

--
/ Alexander Bokovoy

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to