On Fri, Apr 20, 2012 at 12:37:08PM -0400, John Dennis wrote:
> We're supposed to be working on master now, not 2.2. But master has
> dependencies on samba4. Those dependencies can only be resolved on
> F17, an unreleased platform.
> 
> I think it's reasonable for IPA developers to work on the current
> Fedora release (F16) and not have to resort to trying to develop
> inside a vm or run builds inside of mock, etc.
> 
> Even the most basic developer task such as running make-lint won't
> work because it requires you run make to populate the generated
> files. But you can't run make because the configure step fails, it
> fails because it can't satisfy the samba4 dependencies. The samba4
> dependencies can't be satisfied on F16 (I know, I tried).
> 
> FWIW, I tried to build samba4-4.0.0-42alpha18.fc17.src.rpm in mock
> on my local F16 machine and it fails because it depends on libldb
> 1.1.4 which is only in F17, and so on and so on.
> 
> So how are others working on master and how are you getting around
> this problem?

I take samba4 and libldb from the ipa-devel repo. There are even
versions for my very old F15 devel system.

HTH

bye,
Sumit

> 
> -- 
> John Dennis <jden...@redhat.com>
> 
> Looking to carve out IT costs?
> www.redhat.com/carveoutcosts/
> 
> _______________________________________________
> Freeipa-devel mailing list
> Freeipa-devel@redhat.com
> https://www.redhat.com/mailman/listinfo/freeipa-devel

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to