On Wed, Aug 22, 2012 at 05:04:12PM +0300, Alexander Bokovoy wrote:
> On Wed, 22 Aug 2012, Sumit Bose wrote:
> >Hi,
> >
> >this patch fixes a build issue caused by a name change of a library in
> >samba4 beta6. Since we currently always build with the latest samba4
> >version I think we do not need an extra configure check here. I you
> >think otherwise let me known, then I can add a check.
> I think you'd need to modify freeipa.spec.in as we did with the previous
> 'upgrade'.
> 
> BuildRequires:  samba4-devel >= 4.0.0-134

ok, new version attached.

bye,
Sumit

> 
> -- 
> / Alexander Bokovoy
From cd711dd5319c0be37aa542d5fbfb0da3482267c0 Mon Sep 17 00:00:00 2001
From: Sumit Bose <sb...@redhat.com>
Date: Wed, 22 Aug 2012 15:10:31 +0200
Subject: [PATCH] Use libsamba-security instead of libsecurity

In samba4-beta6 the name of a library was changed from libsecurity to
libsamba-security.
---
 daemons/ipa-sam/Makefile.am | 2 +-
 freeipa.spec.in             | 2 +-
 2 Dateien geändert, 2 Zeilen hinzugefügt(+), 2 Zeilen entfernt(-)

diff --git a/daemons/ipa-sam/Makefile.am b/daemons/ipa-sam/Makefile.am
index 
275cce629385b1719544a7832a00e9ee6664b739..ad7e516f0c94f82cc209ee55ff0b67c6a6bd54f9
 100644
--- a/daemons/ipa-sam/Makefile.am
+++ b/daemons/ipa-sam/Makefile.am
@@ -3,7 +3,7 @@ SAMBA40EXTRA_LIBS = $(SAMBA40EXTRA_LIBPATH)     \
                        -lsmbldap               \
                        -lcliauth               \
                        -lpdb                   \
-                       -lsecurity              \
+                       -lsamba-security        \
                        -lsmbconf               \
                        $(NULL)
 
diff --git a/freeipa.spec.in b/freeipa.spec.in
index 
f582f22488a195fd29a1900d6df156d8b56a259f..9e25d5ace0de7bf21e39ce534abd97d5a60d94b4
 100644
--- a/freeipa.spec.in
+++ b/freeipa.spec.in
@@ -31,7 +31,7 @@ BuildRequires:  policycoreutils >= %{POLICYCOREUTILSVER}
 %if 0%{?fedora} >= 16
 BuildRequires:  systemd-units
 %endif
-BuildRequires:  samba4-devel >= 4.0.0-128
+BuildRequires:  samba4-devel >= 4.0.0-134
 BuildRequires:  samba4-python
 BuildRequires:  libtalloc-devel
 BuildRequires:  libtevent-devel
-- 
1.7.11.4

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to