On 11/14/2012 05:16 PM, Martin Kosek wrote:
On 11/14/2012 05:05 PM, Martin Kosek wrote:
On 11/14/2012 02:41 PM, Rob Crittenden wrote:
Martin Kosek wrote:
Remove redundant pki-* package Requires and change PKI server theme
Requires to correct package name.

https://fedorahosted.org/freeipa/ticket/3213

---

The patch fixes broken Requires with the new server theme package name (thanks
Ade for help):

# rpm -q pki-ca
pki-ca-10.0.0-0.52.b3.fc18.noarch
# rpm -qa "*pki-*-theme"
dogtag-pki-server-theme-10.0.0-0.7.b3.fc18.noarch

[root@vm-104 freeipa-3.0.1-1.fc18]# rpm -Uvh --force freeipa-*
error: Failed dependencies:
     dogtag-pki-common-theme is needed by freeipa-server-3.0.1-1.fc18.x86_64


This patch is intended for Fedora 18 only, of course.

Martin


ACK

As discussed on IRC, I made the Requires conditional for Fedora 18 only so that
we do not break environment for people still developing on Fedora 17 (like me).

I also took the opportunity to do some clean ups of compatibility code for old
Fedora 16 and older. Details are in the patch description.

When/if this patch is accepted, Petr Viktorin's patch 0098 should go in too as
we now require the affected pki-ca version on Fedora 18.

Martin


Since we are now touching tar, I also added it to BuildRequires. I think it bit
me once when I built FreeIPA on some super-minimal Fedora compose.

That should not be necessary, see https://fedoraproject.org/wiki/Packaging:Guidelines#Exceptions_2

I assume the thing that bit you was grepping the .spec.in for the BuildRequires, but that shouldn't be a reason to change our spec.

--
PetrĀ³

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to