Find out Kerberos middle version to infer ABI changes in DAL driver.

We cannot load DAL driver into KDC with wrong ABI. This is also needed
to support ipa-devel repository where krb5 1.11 is available for Fedora 18.

Right now krb5 1.11 is in ipa-devel repo for Fedora 18 and FreeIPA git
master packages built against it but bear wrong Requires, resulting in
inability to install FreeIPA on Fedora 18.

--
/ Alexander Bokovoy
>From 8774f12c75c119df2fa38322769a4136cd4f9e01 Mon Sep 17 00:00:00 2001
From: Alexander Bokovoy <aboko...@redhat.com>
Date: Thu, 4 Apr 2013 18:20:25 +0300
Subject: [PATCH] spec: detect Kerberos DAL driver ABI change from installed
 krb5-devel

Find out Kerberos middle version to infer ABI changes in DAL driver.

We cannot load DAL driver into KDC with wrong ABI. This is also needed to
support ipa-devel repository where krb5 1.11 is available for Fedora 18.
---
 freeipa.spec.in | 9 +++++++--
 1 file changed, 7 insertions(+), 2 deletions(-)

diff --git a/freeipa.spec.in b/freeipa.spec.in
index 5e84453..93bba9c 100644
--- a/freeipa.spec.in
+++ b/freeipa.spec.in
@@ -74,6 +74,11 @@ BuildRequires:  check
 BuildRequires:  libsss_idmap-devel
 BuildRequires:  java-1.7.0-openjdk
 
+# Find out Kerberos middle version to infer ABI changes in DAL driver
+# We cannot load DAL driver into KDC with wrong ABI.
+# This is also needed to support ipa-devel repository where krb5 1.11 is 
available for F18
+%global krb5_dal_version %{expand:%(rpmquery --qf='%{VERSION}' krb5-devel|cut 
-d. -f2)}
+
 %description
 IPA is an integrated solution to provide centrally managed Identity (machine,
 user, virtual machines, groups, authentication credentials), Policy
@@ -92,10 +97,10 @@ Requires: 389-ds-base >= 1.3.0.5
 Requires: openldap-clients
 Requires: nss
 Requires: nss-tools
-%if 0%{?fedora} >= 19
+%if 0%{?krb5_dal_version} >= 11
 Requires: krb5-server >= 1.11
 %else
-%if 0%{?fedora} == 18
+%if 0%{krb5_dal_version} == 10
 # krb5 1.11 bumped DAL interface major version, a rebuild is needed
 Requires: krb5-server < 1.11
 Requires: krb5-server >= 1.10
-- 
1.8.1.4

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to