On Wednesday 24 of July 2013 13:19:29 Jan Cholasta wrote:
> Hi,
> 
> On 24.7.2013 12:40, Tomas Babej wrote:
> > Hi,
> >
> > There was already a dependency in server package, however,
> > the correct place for such dependency is in freeipa-python,
> > since the relevant code using keyutils resides there.
> >
> > Both freeipa-server and freeipa-client require freeipa-python.
> >
> > https://fedorahosted.org/freeipa/ticket/3808
> >
> > Tomas
> >
> 
> Please add a changelog entry.
> 
> Honza
> 
> -- 
> Jan Cholasta

Added.

Tomas
>From 1b56c4ed47604dadcb89c801e83434302adc4e3d Mon Sep 17 00:00:00 2001
From: Tomas Babej <tba...@redhat.com>
Date: Tue, 23 Jul 2013 17:21:47 +0200
Subject: [PATCH] Move requirement for keyutils to freeipa-python package

There was already a dependency in server package, however,
the correct place for such dependency is in freeipa-python,
since the relevant code using keyutils resides there.

Both freeipa-server and freeipa-client require freeipa-python.

https://fedorahosted.org/freeipa/ticket/3808
---
 freeipa.spec.in | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/freeipa.spec.in b/freeipa.spec.in
index de8efd8071e1c7899fea13ef362f430dc7219b28..20421908a80759edd45dd46debf8d6c18bc190c4 100644
--- a/freeipa.spec.in
+++ b/freeipa.spec.in
@@ -142,7 +142,6 @@ Requires: subscription-manager
 Requires(preun): python systemd-units
 Requires(postun): python systemd-units
 Requires: python-dns
-Requires: keyutils
 Requires: zip
 Requires: policycoreutils >= %{POLICYCOREUTILSVER}
 Requires: tar
@@ -277,6 +276,7 @@ Group: System Environment/Libraries
 Requires: python-kerberos
 Requires: gnupg
 Requires: iproute
+Requires: keyutils
 Requires: pyOpenSSL
 Requires: python-nss
 Requires: python-lxml
@@ -826,6 +826,9 @@ fi
 %endif  # ! %{ONLY_CLIENT}
 
 %changelog
+* Wed Jul 24 2013 Tomas Babej <tba...@redhat.com> - 3.2.99-9
+- Move requirement for keyutils from freeipa-server to freeipa-python
+
 * Thu Jul 18 2013 Ana Krivokapic <akriv...@redhat.com> - 3.2.99-8
 - Bump minimum version of sssd to 1.10.90 for the 'ipa_server_mode' option.
 
-- 
1.8.3.1

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to