On 09/06/2013 10:35 AM, Alexander Bokovoy wrote:
On Thu, 05 Sep 2013, Petr Viktorin wrote:
On 09/05/2013 08:08 AM, Alexander Bokovoy wrote:
On Wed, 04 Sep 2013, Petr Viktorin wrote:
On 08/19/2013 12:29 PM, Petr Viktorin wrote:
Hello,
The first patch fixes a minor problem that Pylint 1.0 finds in our
code.

The second patch makes make-lint compatible with Pylint 1.0. It
contains
a workaround for a Pylint bug; before pushing this we should wait
for a
while to see if a fixed Pylint is released.


A fixed version of Pylint was released, bug workarounds are no longer
necessary.

Updated patches attached.

https://fedorahosted.org/freeipa/ticket/3865
I tried the patches and still see an error on up to date Fedora 19
(including updates-testing):

./make-lint Traceback (most recent call last):
[...]
TypeError: unbound method infer() must be called with Tuple instance as
first argument (got InferenceContext instance instead)


At this point I'm not sure whether it is astroid's issue or ours...
Astroid did change from 0.24 to 1.0 on August 13th in Fedora (even in
Fedora 19 where version updates after release are generally
discouraged, especially in case of ABI change).

Hello,
Please use Pylint 1.0.0-2. It seems it hasn't reached the mirrors yet,
you have the earlier buggy version.
I do have pylint 1.0.0-2.fc19 and yet it fails with the same error
message. Nothing works, I had to disable make-lint call in Makefile to
continue development.


That is strange; I've confirmed on several machines that the -2.fc19 release fixes this bug.

If you run pylint on the following code, do you also get the "unbound method infer()" error? (It's the upstream bug reproducer)

import collections
Point = collections.namedtuple('Point', ['x', 'y'])
p = Point(x=1.0, y=2.0)
print "Area: %.1f" % (p.x * p.y,)

Can you check the FILE in `pydoc pylint` to make sure you're running pylint from the RPM?

--
PetrĀ³

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to