On 07/04/2014 03:20 PM, Martin Basti wrote:
On Fri, 2014-07-04 at 15:13 +0200, Jan Cholasta wrote:
On 4.7.2014 13:34, Martin Basti wrote:
Hi list,

I need increase version number in ipa-3-3 branch to 2.66, but 2.66 is
already used in ipa-master branch (2.66 Add support for managing user
auth types). Fortunately it is very minor change so If I don't increase
the version nothing happens.

How to solve this problem? Don't increase the version number in ipa-3-3
anymore (?)

If we will increase the IPA-3 API version to number which hits a IPA-4
capability, it could break communication between ipa3-client and
ipa4-server.

Should we try increase the major version sometimes?


Would 2.66.1 work?


IMO 2.65.1, 2.65.2, .. 2.65.x  and never reach 2.66, but I dont know is
this possible in framework?


I do not think it is. But given that we do not offer backwards compatibility with ipa commands, we can add a support in 4.0.x and support both 2.x and 2.x.y form.

Please file a ticket.

Thanks,
Martin

_______________________________________________
Freeipa-devel mailing list
Freeipa-devel@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-devel

Reply via email to