On Wed, Mar 18, 2015 at 01:36:44PM +0100, Martin Kosek wrote:
> On 03/18/2015 01:32 PM, Sumit Bose wrote:
> > On Wed, Mar 18, 2015 at 12:53:04PM +0100, Martin Kosek wrote:
> >> On 03/18/2015 11:22 AM, Jakub Hrozek wrote:
> >>> On Wed, Mar 18, 2015 at 11:01:35AM +0100, Sumit Bose wrote:
> >>>> On Fri, Mar 13, 2015 at 03:14:55PM +0100, Jakub Hrozek wrote:
> >>>>> On Fri, Mar 13, 2015 at 11:56:46AM +0100, Sumit Bose wrote:
> >>>>>> On Wed, Mar 04, 2015 at 06:42:05PM +0100, Sumit Bose wrote:
> >>>>>>> Hi,
> >>>>>>>
> >>>>>>> this is the first patch for 
> >>>>>>> https://fedorahosted.org/freeipa/ticket/4922
> >>>>>>> which converts the check-based tests of the extdom plugin to cmocka.
> >>>>>>>
> >>>>>>> bye,
> >>>>>>> Sumit
> >>>>>>
> >>>>>> Rebased version attached.
> >>>>>>
> >>>>>> bye,
> >>>>>> Sumit
> >>>>>
> >>>>> The test itself is fine, but did freeipa consider moving to cmocka-1.0+
> >>>>> to avoid warnings like:
> >>>>> ipa_extdom_cmocka_tests.c: In function ‘main’:
> >>>>> ipa_extdom_cmocka_tests.c:408:5: warning: ‘_run_tests’ is deprecated
> >>>>> (declared at /usr/include/cmocka.h:2001) [-Wdeprecated-declarations]
> >>>>>      return run_tests(tests);
> >>>>>
> >>>>> But I'm fine with ACKing this patch, the conversion should be done
> >>>>> separately.
> >>>>
> >>>> yes, I found it more flexible to use the old style now because it works
> >>>> with all versions of cmocka. When I converted the remaining check based
> >>>> test to cmocka I will provide a patch which will switch all to the new
> >>>> version.
> >>>>
> >>>> bye,
> >>>> Sumit
> >>>
> >>> Sure, ACK
> >>>
> >>> (sorry, from my point of view it was obvious I was OK with pushing even
> >>> the previous version. Hopefully it's even clearer now :-))
> >>>
> >>
> >> Thanks for this work guys! I would push it, but there is a conflict in 
> >> ipa_extdom.
> > 
> > Rebased version attached.
> > 
> > bye,
> > Sumit
> > 
> 
> Thanks! Pushed to master: d0d79ada379ab809c26a7dc0bbc88b47ab85f744
> 
> What are your next steps for https://fedorahosted.org/freeipa/ticket/4922,
> replace "BuildRequires: check" with cmocka BuildRequires in the FreeIPA
> referential spec file?

yes, the next patch here would be to migrate
ipa-kdb/tests/ipa_kdb_tests.c to cmocka and replace the BuildRequires.

As a last step, if no related issues have shown up on the SSSD side,
make the tests compile with cmocka 1.0 without warnings and add the
version to the BuildRequires.

bye,
Sumit

-- 
Manage your subscription for the Freeipa-devel mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-devel
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code

Reply via email to