On 05/26/2015 03:56 PM, Oleg Fayans wrote:
Hi Petr, team

After playing around with the previous version of your patch applied on
top of the current master branch today in the morning, I still observe
the problem with replica installation, described here:
https://fedorahosted.org/freeipa/ticket/5035

This issue is not fixed with this patch. There is no patch for #5035 yet.

This patch only adds ipalib API and CLI related to topology suffix and topology segment management.

Over 857, patch 857-1 fixes only the 'internal error' which was in previous version(invalid domainslevel-show call).

the session transcript together with ipareplica-install.log and the
errors log of the dirsrv on master are attached.
The following lines in the error log might be of interest:

[26/May/2015:08:46:09 -0400] NSMMReplicationPlugin - Finished total
update of replica "agmt="cn=meToreplica1.pesen.net" (replica1:389)".
Sent 382 entries.
[26/May/2015:08:46:11 -0400] ipa-topology-plugin - ipa_topo_util_modify:
failed to modify entry
(cn=meToreplica1.pesen.net,cn=replica,cn=dc\3Dpesen\2Cdc\3Dnet,cn=mapping 
tree,cn=config):
error 53
[26/May/2015:08:46:17 -0400] repl_version_plugin_recv_acquire_cb - [file
ipa_repl_version.c, line 119]: Incompatible IPA versions, pausing
replication. This server: "20100614120000" remote server: "(null)".
[26/May/2015:08:46:38 -0400] NSMMReplicationPlugin -
agmt="cn=meToreplica1.pesen.net" (replica1:389): Unable to receive the
response for a startReplication extended operation to consumer (Can't
contact LDAP server). Will retry later.
[26/May/2015:08:46:41 -0400] NSMMReplicationPlugin -
agmt="cn=meToreplica1.pesen.net" (replica1:389): Replication bind with
SIMPLE auth resumed
[26/May/2015:08:47:42 -0400] NSMMReplicationPlugin - Beginning total
update of replica
"agmt="cn=masterAgreement1-replica1.pesen.net-pki-tomcat" (replica1:389)".
[26/May/2015:08:47:46 -0400] NSMMReplicationPlugin - Finished total
update of replica
"agmt="cn=masterAgreement1-replica1.pesen.net-pki-tomcat"
(replica1:389)". Sent 70 entries.
[26/May/2015:08:48:28 -0400] repl_version_plugin_recv_acquire_cb - [file
ipa_repl_version.c, line 119]: Incompatible IPA versions, pausing
replication. This server: "20100614120000" remote server: "(null)".
[26/May/2015:08:48:28 -0400] repl_version_plugin_recv_acquire_cb - [file
ipa_repl_version.c, line 119]: Incompatible IPA versions, pausing
replication. This server: "20100614120000" remote server: "(null)".

Should I rebuild the packages with the latest version of your patch on
top of the current master with Tomas' latest Domain Level-related
changes and try again?


On 05/26/2015 03:31 PM, Petr Vobornik wrote:
On 05/26/2015 12:19 PM, Petr Vobornik wrote:
this patch is based on top of my patch #856 and tbabej'
s 325-9.

Obsoletes Ludwig's 0006.

ipalib part of topology management

Design:
- http://www.freeipa.org/page/V4/Manage_replication_topology

https://fedorahosted.org/freeipa/ticket/4302



New version attached:
- domainlevel_show usage changed to domainlevel_get
- updated VERSION
- added more attrs to default_attributes







--
Petr Vobornik

--
Manage your subscription for the Freeipa-devel mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-devel
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code

Reply via email to