ehlo,

it happened many times that freeipa rpms could not be build
in mock because there was build requirement for very new sssd.
Even though it was not necessary to have new sssd among build dependencies.

I've manged to build FreeIPA rpms on rawhide without sssd in build root.
So it means it is not required.

In teory you might need some sssd sub-pacakges for test in build root
e.g. python-sss_nss_idmap, python-sss, python-sssdconfig

But I cannot see a "make test" in upstream spec file.

LS
>From c466be0e769a80fe204fc70675b8fa0ea3efb7b2 Mon Sep 17 00:00:00 2001
From: Lukas Slebodnik <lsleb...@redhat.com>
Date: Mon, 2 Nov 2015 19:52:57 +0000
Subject: [PATCH] SPEC: Drop sssd from BuildRequires

Packaging of sssd was changed and more sub-packages are build
from sssd.src.rpm. Especially python bindings and development packages
are already in sub-packages. As a result of this change the meta package
sssd can be removed from BuildRequires without any problem.

FreeIPA spec file contained build requirement for latest version of
sssd even though the latest sssd was not required for building
FreeIPA rpms. In many cases, it was sufficient just to change requirements
for FreeIPA packages instead of build requirements.
---
 freeipa.spec.in | 1 -
 1 file changed, 1 deletion(-)

diff --git a/freeipa.spec.in b/freeipa.spec.in
index 6a99308..2221712 100644
--- a/freeipa.spec.in
+++ b/freeipa.spec.in
@@ -74,7 +74,6 @@ BuildRequires:  pylint >= 1.0
 BuildRequires:  python-polib
 BuildRequires:  python-libipa_hbac
 BuildRequires:  python-memcached
-BuildRequires:  sssd >= 1.13.1
 BuildRequires:  python-lxml
 BuildRequires:  python-pyasn1 >= 0.0.9a
 BuildRequires:  python-qrcode-core >= 5.0.0
-- 
2.6.2

-- 
Manage your subscription for the Freeipa-devel mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-devel
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code

Reply via email to