Lukas Slebodnik wrote:
> On (23/02/16 17:09), Martin Basti wrote:
>> We cannot guarantee that versions older than 1.4 will work with freeipa code.
>>
>> Patch attached.
> 
>>From a59e72a0b87231c0f2e0d737057550dd532feed7 Mon Sep 17 00:00:00 2001
>> From: Martin Basti <mba...@redhat.com>
>> Date: Tue, 23 Feb 2016 16:58:07 +0100
>> Subject: [PATCH] Set BuildRequires to pylint >= 1.4
>>
>> We can guarantee that only pylint 1.4 and newer will work
>>
>> https://fedorahosted.org/freeipa/ticket/5615
>> ---
>> freeipa.spec.in | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/freeipa.spec.in b/freeipa.spec.in
>> index 
>> 54a11bfc8cced643c19c29c5ada70bacf7540395..219c5ca2f13eaac14746ec4689ba611bbc6fc377
>>  100644
>> --- a/freeipa.spec.in
>> +++ b/freeipa.spec.in
>> @@ -76,7 +76,7 @@ BuildRequires:  python-netaddr
>> BuildRequires:  python-gssapi >= 1.1.2
>> BuildRequires:  python-rhsm
>> BuildRequires:  pyOpenSSL
>> -BuildRequires:  pylint >= 1.0
>> +BuildRequires:  pylint >= 1.4
> 
> I can build rpms even withour pylint and pylint is not executed
> anywhere in spec file. (in other words, my patch was rejected)
> Why does it need to be in BuildRequires?

pylint is part of the in-tree build process (make rpms). It is not
executed when building upstream packages.

rob

-- 
Manage your subscription for the Freeipa-devel mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-devel
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code

Reply via email to