Hi,

attaching patch for one of the failing tests. Failure caused by an assertion that was no longer valid.


Lenka

From 9eb1ec2335145916ce0e83a6f2a9ca6bac056682 Mon Sep 17 00:00:00 2001
From: Lenka Doudova <ldoud...@redhat.com>
Date: Fri, 24 Jun 2016 10:24:40 +0200
Subject: [PATCH] Tests: Fix ipatests/test_ipaserver/test_rpcserver.py

Removed no longer valid assert.
---
 ipatests/test_ipaserver/test_rpcserver.py | 1 -
 1 file changed, 1 deletion(-)

diff --git a/ipatests/test_ipaserver/test_rpcserver.py b/ipatests/test_ipaserver/test_rpcserver.py
index 94ebd062c91aece0558bac4c8bdf1fb01448f605..b739de0b94e0c850404347a0de227f19426a30c2 100644
--- a/ipatests/test_ipaserver/test_rpcserver.py
+++ b/ipatests/test_ipaserver/test_rpcserver.py
@@ -212,7 +212,6 @@ class test_jsonserver(PluginTester):
 
         # Test with invalid JSON-data:
         e = raises(errors.JSONError, o.unmarshal, 'this wont work')
-        assert isinstance(e.error, ValueError)
         if six.PY2:
             assert unicode(e.error) == 'No JSON object could be decoded'
         else:
-- 
2.7.4

-- 
Manage your subscription for the Freeipa-devel mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-devel
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code

Reply via email to