On 08/10/2016 10:59 AM, Ben Lipton wrote:
On 08/10/2016 12:21 PM, Matthew Harmsen wrote:


*The following candidate builds of Dogtag 10.3.5 and ldapjdk on Fedora 24, 25, and 26 (rawhide) consist of the following:*

  * *Fedora 24:*
      o *dogtag-pki-10.3.5-1.fc24
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=789787>*
      o *dogtag-pki-theme-10.3.5-1.fc24
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=789738>*
      o *pki-core-10.3.5-1.fc24
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=789739>*
      o *pki-console-10.3.5-1.fc24
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=789777>*
      o *ldapjdk-4.18-19.fc24
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=790485>*
  * *Fedora 25:*
      o *dogtag-pki-10.3.5-1.fc25
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=790490>*
      o *dogtag-pki-theme-10.3.5-1.fc25
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=790486>*
      o *pki-core-10.3.5-1.fc25
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=790492>*
      o *pki-console-10.3.5-1.fc25
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=790497>*
      o *ldapjdk-4.18-19.fc25
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=790487>*
  * *Fedora 26 (rawhide):*
      o *dogtag-pki-10.3.5-1.fc26
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=790491>*
      o *dogtag-pki-theme-10.3.5-1.fc26
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=790488>*
      o *pki-core-10.3.5-1.fc26
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=790496>*
      o *pki-console-10.3.5-1.fc26
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=790520>*
      o *ldapjdk-4.18-19.fc26
        <http://koji.fedoraproject.org/koji/buildinfo?buildID=790489>*

*Please provide Karma for the following builds:*

  * *Fedora 24:*
      o *https://bodhi.fedoraproject.org/updates/FEDORA-2016-059eb8aaee
        dogtag-pki-10.3.5-1.fc24
        <https://bodhi.fedoraproject.org/updates/FEDORA-2016-059eb8aaee>*
      o *https://bodhi.fedoraproject.org/updates/FEDORA-2016-9f1baf574f
        dogtag-pki-theme-10.3.5-1.fc24
        <https://bodhi.fedoraproject.org/updates/FEDORA-2016-9f1baf574f>*
      o *https://bodhi.fedoraproject.org/updates/FEDORA-2016-4d226a5f7e
        pki-core-10.3.5-1.fc24
        <https://bodhi.fedoraproject.org/updates/FEDORA-2016-4d226a5f7e>*
      o *https://bodhi.fedoraproject.org/updates/FEDORA-2016-dd16599bc7
        pki-console-10.3.5-1.fc24
        <https://bodhi.fedoraproject.org/updates/FEDORA-2016-dd16599bc7>*
      o *https://bodhi.fedoraproject.org/updates/FEDORA-2016-1835df9b39
        ldapjdk-4.18-19.fc24
        <https://bodhi.fedoraproject.org/updates/FEDORA-2016-1835df9b39>
        *
  * *Fedora 25:*
      o *https://bodhi.fedoraproject.org/updates/FEDORA-2016-85261e13c5
           dogtag-pki-10.3.5-1.fc25*
      o *https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f0224b152
           dogtag-pki-theme-10.3.5-1.fc25*
      o *https://bodhi.fedoraproject.org/updates/FEDORA-2016-0a384ead60
        pki-core-10.3.5-1.fc25
        <https://bodhi.fedoraproject.org/updates/FEDORA-2016-0a384ead60>*
      o *https://bodhi.fedoraproject.org/updates/FEDORA-2016-849cbeecb1
        pki-console-10.3.5-1.fc25
        <https://bodhi.fedoraproject.org/updates/FEDORA-2016-849cbeecb1>*
      o *https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f6bc9b601
        ldapjdk-4.18-19.fc25
        <https://bodhi.fedoraproject.org/updates/FEDORA-2016-3f6bc9b601>
        *



On Fedora 24 I am unable to upgrade to these packages without manual intervention:
[root@vm freeipa]# dnf update --allowerasing --best
Last metadata expiration check: 2:08:29 ago on Wed Aug 10 16:38:24 2016.
Error: nothing provides resteasy-atom-provider >= 3.0.17-1 needed by pki-base-java-10.3.5-1.fc24.noarch. package pki-tools-10.3.5-1.fc24.x86_64 requires pki-base-java = 10.3.5-1.fc24, but none of the providers can be installed. nothing provides resteasy-atom-provider >= 3.0.17-1 needed by pki-base-java-10.3.5-1.fc24.noarch. nothing provides resteasy-atom-provider >= 3.0.17-1 needed by pki-base-java-10.3.5-1.fc24.noarch. nothing provides resteasy-atom-provider >= 3.0.17-1 needed by pki-base-java-10.3.5-1.fc24.noarch. nothing provides resteasy-atom-provider >= 3.0.17-1 needed by pki-base-java-10.3.5-1.fc24.noarch
[root@vm freeipa]# rpm -q resteasy-atom-provider
resteasy-atom-provider-3.0.6-11.fc24.noarch

Am I doing something wrong, or does the new resteasy need to be added back to testing? (https://bodhi.fedoraproject.org/updates/FEDORA-2016-d80872c309)

Ben

Ben,

No, the resteasy 3.0.17 builds received bad karma because they were utilized with an incompatible pki-core 10.3.3 as used by FreeIPA and the packages were thus obsoleted.

This build fixes that problem, but requires the version of resteasy 3.0.17 that was obsoleted.

We are going to inquire if resteasy 3.0.17 for Fedora 24 can be re-issued to bodhi. If the change is going to be backed out permanently, it would require yet another re-spin of the pki-core bits.

Stay tuned,

-- Matt

-- 
Manage your subscription for the Freeipa-devel mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-devel
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code

Reply via email to