Hi,

On 25.8.2016 11:27, Alexander Bokovoy wrote:
Hi,

attached patch moves ipa CLI to freeipa-client and obsoletes
freeipa-admintools

The Obsoletes (both) should be on version < 4.4.1 rather than %{version}, as per Fedora packaging guidelines [1].

Please move the Obsoletes and Provides on %{name}-admintools right below Group (Obsoletes first) and put a newline between the %{alt_name}-client and %{alt_name}-admintools blocks, for consistent layout accross all subpackages in the spec file.


Solves https://fedorahosted.org/freeipa/ticket/5934

Here is how upgrade looks when running 'dnf':

Upgrading:
freeipa-client                                 x86_64
4.4.0.201608250913GIT9c20682-0.fc24                        @commandline
146 k
    replacing  freeipa-admintools.noarch
4.4.0.201608051228GIT590e30f-0.fc24

I'm going to test with yum as well, for RHEL and CentOS.

Honza

[1] <https://fedoraproject.org/wiki/Upgrade_paths_%E2%80%94_renaming_or_splitting_packages>

--
Jan Cholasta

--
Manage your subscription for the Freeipa-devel mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-devel
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code

Reply via email to