URL: https://github.com/freeipa/freeipa/pull/336
Title: #336: [py3] pki: add missing depedency pki-base[-python3]

tiran commented:
What I meant with different minimal version, FreeIPA requires pki-ca and kra 
10.3.5 and newer.

Requires: pki-ca >= 10.3.5-6
Requires: pki-kra >= 10.3.5-6

Is there a reason why the minimal version for the pki-base package is smaller? 
All Dogtag PKI packages pull in other PKI packages with exactly the same 
version (e.g. ```pki-base = %{version}-%{release}```). Even more import, there 
is no Python 3 pki-base package for 10.2! I added the new package for 10.3. :)

Lastly pki-base just happens to provide Python 2 packages for now. In 10.4 or 
10.5 we may switch over the Python 3. If you need ```pki``` Python package with 
guaranteed Python 2 support, then please depend on pki-base-python2 (currently 
provided by pki-base).


See the full comment at 
Manage your subscription for the Freeipa-devel mailing list:
Contribute to FreeIPA: http://www.freeipa.org/page/Contribute/Code

Reply via email to