Hi Jakub

  Thanks and it does not come off that way at all.  I made the same
recommendations.  I can only control the IPA servers and they are at 6.9
but the typical reason for not moving up... app not tested on higher level.




Sean Hogan










From:   Jakub Hrozek via FreeIPA-users
            <freeipa-users@lists.fedorahosted.org>
To:     freeipa-users@lists.fedorahosted.org
Cc:     Jakub Hrozek <jhro...@redhat.com>
Date:   06/28/2017 07:47 AM
Subject:        [Freeipa-users] Re: (no subject)



On Wed, Jun 28, 2017 at 07:04:58AM -0700, Sean Hogan via FreeIPA-users
wrote:
>
> Hi All,
>
>   We are having an issue performing RHEL 6.6 to 6.7 upgrade with SSSD.
The
> systems are already enrolled and working in IPA 3.0.0-50 using 6.6
client.
> We yum update and sssd gives this
>
>  Non-fatal POSTTRANS scriptlet failure in rpm package
>  sssd-1.12.4-47.el6_7.8.ppc64
>  warning: %posttrans(sssd-1.12.4-47.el6_7.8.ppc64) scriptlet
>  failed, exit status 1
>

I'm sorry if this comes off as less than helpful, but unless you have a
critical reason to use 6.7, please upgrade to 6.8 or even 6.9. You don't
have to upgrade the whole distro, but at least the sssd stack.

There was a ton of bugfixes between 6.7 and 6.8..

>
>
>
> Seems to install however sssd will no longer start.  I can run ldap
> searches against the IPA server and kinit without issue
> I have un-enrolled the client and re-enrolled to no avail... once enroll
> gets to starting sssd it says sssd restart failed and continues to
enroll.
> I have reinstalled sssd, ipa client and c-ares, I have removed the sssd
> cache db.
>
> The really strange part is if we wait approx 24 hours sssd starts working
> again which we have reproduced on 2 servers we are testing with... are we
> missing some sort of lease or cache?  Using this to remove the sssd db
> rm -rf /var/lib/sss/db/*
>
>
>
> Here is a piece of the gdb core dump
> Core was generated by `/usr/libexec/sssd/sssd_pac --uid 0 --gid 0 -d
0x37f0

This is a bug in the sssd_pac responder. I couldn't find any related
bug report upstream or in RHBZ, but I would really suggest upgrading
first.

If the sssd_pac service still crashes, then we need to investiage the
problem further. Seeing that you're using ppc, chances are there might be
an endianess issue, but I can't think of any recent one.
_______________________________________________
FreeIPA-users mailing list -- freeipa-users@lists.fedorahosted.org
To unsubscribe send an email to freeipa-users-le...@lists.fedorahosted.org


_______________________________________________
FreeIPA-users mailing list -- freeipa-users@lists.fedorahosted.org
To unsubscribe send an email to freeipa-users-le...@lists.fedorahosted.org

Reply via email to