On 04.01.2018 12:48, Andrew Radygin via FreeIPA-users wrote:
> Flo,
> I've checked certmonger dbus config - it's okay and identical to another
> one working.
> But after restart dbus - certmoner configured and installed successful.
> 
> Although I have another problem error now:
> 
> ============
> # apt-get install freeipa-client
> Reading package lists... Done
> Building dependency tree      
> Reading state information... Done
> freeipa-client is already the newest version.
> 0 upgraded, 0 newly installed, 0 to remove and 427 not upgraded.
> 1 not fully installed or removed.
> After this operation, 0 B of additional disk space will be used.
> Do you want to continue? [Y/n]
> Setting up freeipa-client (4.4.4-4) ...
> dpkg: error processing package freeipa-client (--configure):
>  subprocess installed post-installation script returned error exit status 1
> Errors were encountered while processing:
>  freeipa-client
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> ===============
> 
> # ps auxf |grep cert
> root     11868  0.0  0.0  12772   980 pts/0    S+   13:35  
> 0:00          \_ grep cert
> root     11781  0.0  0.1  70728  5072 ?        Ss   13:31   0:00
> /usr/sbin/certmonger -S -p /var/run/certmonger.pid -n
> 
> # cat /var/log/dpkg.log
> 2018-01-04 13:31:26 startup packages configure
> 2018-01-04 13:31:26 configure certmonger:amd64 0.79.3-1 <none>
> 2018-01-04 13:31:26 status half-configured certmonger:amd64 0.79.3-1
> 2018-01-04 13:31:26 status installed certmonger:amd64 0.79.3-1
> 2018-01-04 13:31:27 configure freeipa-client:amd64 4.4.4-4 <none>
> 2018-01-04 13:31:27 status unpacked freeipa-client:amd64 4.4.4-4
> 2018-01-04 13:31:27 status half-configured freeipa-client:amd64 4.4.4-4
> 2018-01-04 13:32:03 startup packages configure
> 2018-01-04 13:32:03 configure freeipa-client:amd64 4.4.4-4 <none>
> 2018-01-04 13:32:03 status half-configured freeipa-client:amd64 4.4.4-4
> 
> =======
> 
> From /var/lib/dpkg/info/freeipa-client.postinst I've found following log
> file - /var/log/ipaclient-upgrade.log
> And there is such messages:
> 
> Traceback (most recent call last):
>   File "<string>", line 1, in <module>
>   File "/usr/lib/python2.7/dist-packages/ipapython/certdb.py", line 31,
> in <module>
>     from ipalib import x509
>   File "/usr/lib/python2.7/dist-packages/ipalib/__init__.py", line 885,
> in <module>
>     from ipalib import plugable
>   File "/usr/lib/python2.7/dist-packages/ipalib/plugable.py", line 41,
> in <module>
>     from ipalib import errors
>   File "/usr/lib/python2.7/dist-packages/ipalib/errors.py", line 109, in
> <module>
>     from ipalib.text import ngettext as ungettext
>   File "/usr/lib/python2.7/dist-packages/ipalib/text.py", line 193, in
> <module>
>     @six.python_2_unicode_compatible
> AttributeError: 'module' object has no attribute
> 'python_2_unicode_compatible'

python-six is too old, 1.8.0 doesn't have that, 1.10.0 from stretch
(Debian 9) does.



-- 
t
_______________________________________________
FreeIPA-users mailing list -- freeipa-users@lists.fedorahosted.org
To unsubscribe send an email to freeipa-users-le...@lists.fedorahosted.org

Reply via email to