Aravindh Sampathkumar via FreeIPA-users wrote:
> Hello list,
> I'm trying to move from NIS to FreeIPA for authentication in a cluster. 
> I already setup FreeIPA server running version 4.5.0 on CentOS 7 and it
> works good. I've got a few Centos 7 and Fedora 23 clients talking to it
> all good.
> We have a few legacy nodes that *fedora 14* and *fedora 20* and I'm not
> allowed to replace the nodes just yet. I would like for them to be able
> to talk to the same FreeIPA server as well. I tried to install freeIPA
> client, but with no success. Appreciate any help/tips with getting the
> latest freeipa-client installed and running on fedora 14.
> I tried to install "ipa-client" available in Fedora 11 updates repository..
> root@c04b13 ~]# yum install ipa-client
> ...
> ---> Package ipa-client.x86_64 0:1.2.2-6.fc14 set to be installed
> --> Finished Dependency Resolution
> Dependencies Resolved
> ...
> Processing delta metadata
> Package(s) data still to download: 48 k
> ipa-client-1.2.2-6.fc14.x86_64.rpm                                            
> |  48
> ...
> Running Transaction
>   Installing     :
> ipa-client-1.2.2-6.fc14.x86_64                                                
> Installed:
>   ipa-client.x86_64
> 0:1.2.2-6.fc14                                                                
> Complete!
> [root@c04b13 ~]# ipa-client-install
> DNS discovery failed to determine your DNS domain
> Please provide the domain name of your IPA server (ex:
> DNS discovery failed to find the IPA Server
> Please provide your IPA server name (ex:
> Failed to verify that is an IPA Server.
> This may mean that the remote server is not up or is not reachable
> due to network or firewall settings.
> The same ipa-client-install works just fine on a Fedora 23 box on the
> same network. 
> My question: Is there a way to get the latest FreeIPA-client package
> installed on this old fedora 14 box? 
> I tried to download the rpm file from
> (
> and install it using
> yum --nogpgcheck localinstall freeipa-client-4.6.1-4.fc28.x86_64.rpm
> But, it only throws dependancy errors as in the attached console log.
> Any ideas about how I can get the freeipa-client package on f14?

You can't, don't try.

You are probably best off doing a manual configuration. You could try
the config suggested by: ipa-advise config-redhat-sssd-before-1-9

If that doesn't work you'll need to manually configure it using whatever
ldap provider was available then. It's so long ago I can't even remember.

Fedora 14 is ancient, released 8 years ago!

It also contains basically the first release of freeIPA which is likely
why the client isn't working.

FreeIPA-users mailing list --
To unsubscribe send an email to

Reply via email to