Hi Uzor,

I had the same problem. You need to add the following line to your /etc/httpd/conf.d/ipa.conf file:


Alias /ipa/ui "/usr/share/ipa/static"

I added this line right before directory instructions for folder /usr/share/ipa/static, on line 88.
Restart httpd server and you should have access to web interface.

Regards,
Miljan

On 12/28/10 6:21 PM, Uzor Ide wrote:
Hi all

I just noticed that am unable to access the web interface for freeipa. I had updated the server 2.0 alpha-5 and then beta version that came out some days ago. but since I do not use that web interface I have not idea when I lost the web interface ability. Now, though when I try to get to the web interface from a kerberized account all I get is an http error

"The requested URL /ipa/ui was not found on this server"

In the httpd error log, all that is there are

[Tue Dec 28 11:55:29 2010] [error] [client 192.168.17.13] File does not exist: /var/www/html/favicon.ico [Tue Dec 28 11:55:32 2010] [error] [client 192.168.17.13] File does not exist: /var/www/html/favicon.ico

access_log shows:

192.168.17.13 - - [28/Dec/2010:11:56:35 -0500] "GET /ipa/ui HTTP/1.1" 301 319 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13) Gecko/20101209 Fedora/3.6.13-1.fc13 Firefox/3.6.13" 192.168.17.13 - - [28/Dec/2010:11:56:35 -0500] "GET /ipa/ui HTTP/1.1" 401 1164 192.168.17.13 - u...@mydomain [28/Dec/2010:11:56:36 -0500] "GET /ipa/ui HTTP/1.1" 404 174

ssl_error_log is empty
ipa files version are:
ipa-python-2.0.0.pre1-0.fc13.
i686
ipa-admintools-2.0.0.pre1-0.fc13.i686
ipa-server-2.0.0.pre1-0.fc13.i686
ipa-client-2.0.0.pre1-0.fc13.i686

All my command line still works.

Thanks for you help

Ide


_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users
_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to