Thanks again!  To answer your queries,
    -- I get the same error for su - nasir    -- I don't think ssh is not 
creating oddjobd ; see the error in the trailing mail which I am getting in the 
konsole while trying to login. It does try to create home folder    -- The 
client IPA machine was created with --mkhomedir switch. Also, I can 
see pam_oddjob_mkhomedir.so entry in the system-auth and password-auth files of 
pam(But not in ssh file, though I manually tried once to insert in ssh file and 
then it was trying to create the home folder twice while SSHing !!).    -- As I 
said in previous mail, Pre-created directories get autmounted and setup 
correctly when I try to login to NFS server(cohort.org.hugyat) but NOT to other 
machines.    -- When autofs is disabled, directories get created successfully 
in the local hard disk on all the machines configured with --mkhomedir switch
Any clue ?
Thanks and regards,
Nidal



  

    
    
  
  
    Lets try to isolate it a little further.  If you log in to that
    machine as root, and then do su - nasir, does it let you create the
    directory or give you the same error?  I'm guessing it is ssh that
    is complaining here.  If the mount point is set up correctly, you
    should be able to crete and chown the /home/nasir directory, either
    via odd job, or just test it as root.

    

    What I am guessing is happening here is that ssh is not triggereing
    the odd job creation of the home directory.  Either that, or this
    particular IPA client was run without the switch to create the
    home-dir.  If Automount is commented out, does the /home/nasir
    directory get created on the local disk?

    

    

    On 05/16/2011 09:19 PM, nasir nasir wrote:
    
      
        
          
            
              Thanks again!
              

              
              No! it allows auto mount that pre created home folder
                ONLY  to the NFS server. For e.g if I have /xtra/home/nasir
                alread created, then it automatically mounts  while
                login to NFS server ( ssh -l nasir NFS_SERVER ). But
                when I try to login as the same user to some other
                machine ( ssh -l nasir ANY_IPA_MACHINE) it gives the
                following error,
              

              
              
                [root@openipa ~]# ssh -l nasir 192.168.1.222 -X
                nasir@192.168.1.222's password: 
                Creating home directory for nasir.
                Last login: Tue May 17 04:06:43 2011 from
                    openipa.cohort.org
                Could not chdir to home directory /home/nasir:
                    No such file or directory
                -sh-4.1$ ls
              
              

              
              So it is not working right ? Hope it is clear to you
                now.
              

              
              Thanks and regards,
              Nidal
              

              
              

              
              

              
                
                  
                    
                      
                        
                          
                            If I manually create one home folder(
                              e.g /xtra/home/abc ) under than,
                              then I can mount it, but nothing can be
                              written to it by the user as it gives
                              permission denied error.
                          
                        
                      
                    
                  
                  

                  Yes, but it should allow the root user to create and
                  chown the directory, so the autocreation of home dirs
                  should work.

                  

                
                

                
              
            
          
        
      
    
    

  

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to