Pavel Zhukov wrote:
Thank you for help. but automount doesn't work anyway.

cat /etc/sysconfig/autofs | egrep -v "#.*"
TIMEOUT=300
BROWSE_MODE="no"
MOUNT_NFS_DEFAULT_PROTOCOL=4
LOGGING="debug"
USE_MISC_DEVICE="yes"
MAP_OBJECT_CLASS="automountMap"
ENTRY_OBJECT_CLASS="automount"
MAP_ATTRIBUTE="automountMapName"
ENTRY_ATTRIBUTE="automountKey"
VALUE_ATTRIBUTE="automountInformation"
LDAP_URI="ldap://freeipa.home.zhukoff.net";
SEARCH_BASE="cn=default,cn=automount,dc=home,dc=zhukoff,dc=net"

cat /var/log/messages | grep automount
Jul 6 22:35:31 ipaclient automount[1257]: st_expire: state 1 path /net
Jul 6 22:35:31 ipaclient automount[1257]: expire_proc: exp_proc =
139679846762240 path /net
Jul 6 22:35:31 ipaclient automount[1257]: expire_cleanup: got thid
139679846762240 path /net stat 0
Jul 6 22:35:31 ipaclient automount[1257]: expire_cleanup: sigchld: exp
139679846762240 finished, switching from 2 to 1
Jul 6 22:35:31 ipaclient automount[1257]: st_ready: st_ready(): state =
2 path /net
Jul 6 22:36:00 ipaclient automount[1257]: st_expire: state 1 path /misc
Jul 6 22:36:00 ipaclient automount[1257]: expire_proc: exp_proc =
139679846762240 path /misc
Jul 6 22:36:00 ipaclient automount[1257]: expire_cleanup: got thid
139679846762240 path /misc stat 0
Jul 6 22:36:00 ipaclient automount[1257]: expire_cleanup: sigchld: exp
139679846762240 finished, switching from 2 to 1
Jul 6 22:36:00 ipaclient automount[1257]: st_ready: st_ready(): state =
2 path /misc

mount | grep autofs
...... (some /dev and /sys)
/etc/auto.misc on /misc type autofs
(rw,relatime,fd=7,pgrp=1257,timeout=300,minproto=5,maxproto=5,indirect)
-hosts on /net type autofs
(rw,relatime,fd=13,pgrp=1257,timeout=300,minproto=5,maxproto=5,indirect)

Can you check the 389-ds access log on the server when you restart the autofs service on the client? This should show us if it is connecting, what it is searching for and how many (if any) entries it found. Note that 389-ds buffers the access log so it could be a few seconds before you see any output.

rob


Pavel
On Wed, 06 Jul 2011 09:11:29 -0400
Rob Crittenden <rcrit...@redhat.com> wrote:
Pavel Zhukov wrote:
Hi all

I'm trying to install and configure FreeIPA and automount
https://fedoraproject.org/wiki/QA:Testcase_freeipav2_automount

/etc/sysconfig/autofs
MAP_OBJECT_CLASS="automountMap"
ENTRY_OBJECT_CLASS="automount"
MAP_ATTRIBUTE="automountMapName"
ENTRY_ATTRIBUTE="automountKey"
VALUE_ATTRIBUTE="automountInformation"
LDAP_URI="ldap://freeipa.home.zhukoff.net";
##SEARCH_BASE="cn=dafault,cn=automount,dc=home,dc=zhukoff,dc=net"
SEARCH_BASE="cn=automount,dc=home,dc=zhukoff,dc=net"

$ showmount -e freeipa.home.zhukoff.net
Export list for freeipa.home.zhukoff.net:
/share/man 192.168.12.0/16
/home 192.168.12.0/16


$ ipa automountkey-find default auto.master
Key: /-
Mount information: auto.direct

Key: /share
Mount information: auto.share
----------------------------
Number of entries returned 2
----------------------------
$ ipa automountkey-find default auto.share
Key: man
Mount information: -ro,soft,rsize=8192,wsize=8192
freeipa.home.zhukoff.net:/share/man
----------------------------
Number of entries returned 1
----------------------------
$ ipa automountkey-find default auto.master
Key: /-
Mount information: auto.direct

Key: /share
Mount information: auto.share
----------------------------
Number of entries returned 2
----------------------------

/var/log/messages:
Jul 4 00:40:51 ipaclient automount[2227]: st_expire: state 1 path /net
Jul 4 00:40:51 ipaclient automount[2227]: expire_proc: exp_proc =
139786245711616 path /net
Jul 4 00:40:51 ipaclient automount[2227]: expire_cleanup: got thid
139786245711616 path /net stat 0
Jul 4 00:40:51 ipaclient automount[2227]: expire_cleanup: sigchld: exp
139786245711616 finished, switching from 2 to 1
Jul 4 00:40:51 ipaclient automount[2227]: st_ready: st_ready(): state =
2 path /net

But automount doesn't work. Mount nothing.
Can anybody help me?


Two suggestions for /etc/sysconfig/autofs on ipaclient:

1. Set LOGGING="debug"
2. Set SEARCH_BASE to
cn=default,cn=automount,dc=home,dc=zhukoff,dc=net. Your commented-out
line has default misspelled.

Don't forget to restart autofs service

rob


_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to