Hi,

this is mostly actual for developers but I'm including freeipa-users@ 
just in case. If you are not using ipa-devel, you can ignore this 
message.

Development repository for FreeIPA-related packages, ipa-devel, does 
not have pki-ca package built for Fedora 16. This means that after 
upgrade from Fedora 15 to Fedora 16, a pki-ca package installed from 
ipa-devel repo will not be updated to Fedora 16-specific pki-ca 
package from fedora-updates:

# rpm -q pki-ca
pki-ca-9.0.16-1.20111122T0545z.fc15.noarch
# yum install pki-ca-9.0.16-1.fc16
Setting up Install Process
Package matching pki-ca-9.0.16-1.fc16.noarch already installed. 
Checking for update.
Nothing to do

As result, pki-ca will not have systemd support and FreeIPA in Fedora 
16 will not work with integrated Certificate Authority.

I've filed ticket 61 for pki: https://fedorahosted.org/pki/ticket/61, 
but person responsible for the repository is not available until 
Monday so if you are planning to upgrade from Fedora 15 to Fedora 16 
and are using ipa-devel repo, please postpone the upgrade until next 
week.

Additionaly, please be aware that ipa-devel repo is for development 
and early testing purposes only. No guarantees are given out for 
packages installed from ipa-devel. Of course, if you are participating 
in FreeIPA/Dogtag/389-ds development, you already know that.
-- 
/ Alexander Bokovoy

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to