On Fri, 2012-02-10 at 16:18 -0500, John Dennis wrote:
> On 02/10/2012 03:49 PM, Marco Pizzoli wrote:
> > --> Finished Dependency Resolution
> > *Error: Protected multilib versions: libldb-1.1.0-1.fc16.i686 !=
> > libldb-1.1.4-1.fc16.1.x86_64*
> 
> This error is because you've got both a 32-bit and 64-bit version of 
> libldb installed, note how the 32-bit version is 1.1.0 and the 64-bit 
> version is 1.1.4, they're not the same.
> 
> However the ipa-devel repo does have both the 32-bit and 64-bit version 
> of 1.1.4 available in the x86-64 repo
> 
> ipa-devel/fedora/16/x86_64/os/libldb-1.1.4-1.fc16.1.i686.rpm
> ipa-devel/fedora/16/x86_64/os/libldb-1.1.4-1.fc16.1.x86_64.rpm
> 
> So the repo looks good, not sure what yum is complaining about, it 
> should see both 32-bit and 64-bit is available for version 1.1.4 and 
> install both, unless of course you've got a dependency on the 1.1.0 
> 32-bit version, but yum should tell you that.

SSSD has to be built against a specific version of LDB. It's not
compatible with mixed-versions in your install. Also, yum SHOULD have
prevented installing different versions of libldb in multilib. I'm not
sure why it didn't.

So with all that said, the easiest thing to do would be to 'yum remove
libldb.i686' and then try updating again.

Attachment: signature.asc
Description: This is a digitally signed message part

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to