On Sat, Mar 10, 2012 at 10:49 PM, Alexander Bokovoy <aboko...@redhat.com> wrote:
> On Sat, 10 Mar 2012, Stephen Ingram wrote:
>
>> I'm testing the new FreeIPA 2.1.90 rc1 on a fresh Fedora 17 alpha this
>> weekend. I started by installing the freeipa-server package and the
>> dns packages hoping they would pull in all of the dependencies.

...snip...

> SELinux policy in existing dogtag packages is broken. It is already
> fixed in the development tree but no new package is available yet as I
> said above. As SELinux policy for dogtag is broken, appropriate
> operations that pkicreate was supposed to perform went wrong.
>
>> As I'm still not to up on the new systemd stuff, I'm not sure what to
>> do next. Any suggestions?
> Please try with permissive mode and clear VM.

Tried in permissive mode. Almost made it all the way through.
Permissions are correct on those files (/run/pki-ca.pid and
/var/log/pki-ca/catalina.out) now.

Install stopped with error during the LDAP updates with "unexpected
error - 'set' object does not support item assignment". IPA server
install logs say:

...

2012-03-11T07:15:05Z DEBUG      ( 1.3.6.1.4.1.15953.9.1.10    NAME
'sudoOrder'    DESC 'an integer to order the sudoRole entries'
EQUALITY integerMatch    ORDERING integerOrderingMatch    SYNTAX
1.3.6.1.4.1.1466.115.121.1.27    X-ORIGIN 'SUDO' )
2012-03-11T07:15:05Z DEBUG 'set' object does not support item
assignment  File "/sbin/ipa-server-install", line 1092, in <module>
rval = main()

  File "/sbin/ipa-server-install", line 1005, in main    ds.apply_updates()

  File "/usr/lib/python2.7/site-packages/ipaserver/install/dsinstance.py",
line 425, in apply_updates  ld.update(files)

  File "/usr/lib/python2.7/site-packages/ipaserver/install/ldapupdate.py",
line 817, in update self.__run_updates(dn_list, all_updates)

  File "/usr/lib/python2.7/site-packages/ipaserver/install/ldapupdate.py",
line 771, in __run_updates self.__update_record(all_updates[dn])

  File "/usr/lib/python2.7/site-packages/ipaserver/install/ldapupdate.py",
line 657, in __update_record updated =
self.is_schema_updated(entry.toDict())

  File "/usr/lib/python2.7/site-packages/ipaserver/install/ldapupdate.py",
line 589, in is_schema_updated  s = ldap.schema.SubSchema(s)

  File "/usr/lib/python2.7/site-packages/ldap/schema/subentry.py",
line 125, in __init__ self.non_unique_names[se_class][se_id] = None

Steve

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to