On 04/13/2012 11:39 AM, Dan Scott wrote:
Hi,

I've been using FreeIPA for a couple of years (Upgraded/Migrated from
FreeIPA 1). The servers are in various states (Some upgraded from
Fedora 10/11 through each release, some fresh installs of Fedora
15/16). I've also had to add/remove replicas many times - and run into
problems installing which required some manual intervention.

I'm convinced that my LDAP directories contain lots of cruft which has
built up and is causing problems on my system. There may even be some
corruption since there's an entry which I'm unable to remove - this
entry does not get replicated to the other servers.

What version of 389-ds-base is this? Do you get any errors? It just silently fails to delete this particular entry?

I also see
inconsistent replication states on the servers. i.e. server1 shows
that it's replicating with server2 but server2 does not show that it's
replicating with server1.

Do you have errors in the server2 log showing that it is attempting to replicate with server1 but failing with some error?


Is there some way that I can refresh/clean my LDAP directories and
ensure that everything's running correctly.

We first need to find out what's going on and why you are seeing these failures before we can recommend a particular course of action. There is currently no "find all of my problems and fix them" command.


Thanks,

Dan

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to