On 05/31/2012 03:33 PM, Chris Evich wrote:
On 05/30/2012 03:14 PM, Rob Crittenden wrote:
The current 389-ds-base package in Fedora 17 is known to not work with
IPA. This is any of the 1.2.11.x builds through 1.2.11.4.

The only solution we have right now is to downgrade to 1.2.10.4. This is
unfortunately not in any yum repositories. To install it you can either
download the packages manually from
http://koji.fedoraproject.org/koji/buildinfo?buildID=308732 or use the
koji tool to retrieve them:

# koji download-build 389-ds-base-1.2.10.4-2.fc17

Then install the right bits for your architecture. You'll want to remove
any existing 389-ds-base bits:

# rpm -e 389-ds-base 389-ds-base-libs

We're working with the 389-ds team to fix this. We do not currently have
an ETA.

rob

And! remember to add 389-ds-base and 389-ds-base-libs to /etc/yum.conf exclude
list (temporarily). Otherwise it's easy to accidentally wreck your setup with
a casual yum update (not that I would ever casually update my systems, nope,
never).

Hello,

these commands should do all magic for you:

    sudo yum install koji
    koji download-build 389-ds-base-1.2.10.4-2.fc17

    sudo yum remove '389-ds-*'
    sudo yum install 389-ds-*.fc17.x86_64.rpm
    sudo yum install yum-plugin-versionlock
    sudo yum versionlock 389-ds-base{,-devel,-libs}

Credit goes to Petr^3 Viktorin.


Petr^2 Spacek

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to