Hi Rich,

That worked!!
Thank you Rick and Alexander for the kind help!

Best,

-Ikaro


On Tue, Sep 25, 2012 at 4:29 PM, Rich Megginson <rmegg...@redhat.com> wrote:
> On 09/25/2012 11:39 AM, Dan Scott wrote:
>>
>> Hi,
>>
>> We've tried starting the service properly - the dirsrv process still
>> won't start properly:
>>
>> [25/Sep/2012:13:28:10 -0400] - 389-Directory/1.2.10.14 B2012.201.358
>> starting up
>> [25/Sep/2012:13:28:10 -0400] - Detected Disorderly Shutdown last time
>> Directory Server was running, recovering database.
>> [25/Sep/2012:13:28:42 -0400] - 389-Directory/1.2.10.14 B2012.201.358
>> starting up
>> [25/Sep/2012:13:28:42 -0400] - Detected Disorderly Shutdown last time
>> Directory Server was running, recovering database.
>> [25/Sep/2012:13:28:48 -0400] - Skipping CoS Definition cn=Password
>> Policy,cn=accounts,dc=ecg,dc=mit,dc=edu--no CoS Templates found, which
>> should be added before the CoS Definition.
>> [25/Sep/2012:13:29:01 -0400] NSMMReplicationPlugin - changelog program
>> - cl5DBData2Entry: invalid data version
>> [25/Sep/2012:13:29:02 -0400] NSMMReplicationPlugin - changelog program
>> - cl5Open: failed to open changelog
>> [25/Sep/2012:13:29:02 -0400] NSMMReplicationPlugin - changelog program
>> - changelog5_init: failed to start changelog at
>> /var/lib/dirsrv/slapd-ECG-MIT-EDU/cldb
>> [25/Sep/2012:13:29:02 -0400] - Failed to start object plugin
>> Multimaster Replication Plugin
>> [25/Sep/2012:13:29:03 -0400] NSMMReplicationPlugin - changelog program
>> - cl5DBData2Entry: invalid data version
>> [25/Sep/2012:13:29:03 -0400] NSMMReplicationPlugin - changelog program
>> - cl5Open: failed to open changelog
>> [25/Sep/2012:13:29:03 -0400] NSMMReplicationPlugin - changelog program
>> - changelog5_init: failed to start changelog at
>> /var/lib/dirsrv/slapd-ECG-MIT-EDU/cldb
>> [25/Sep/2012:13:29:03 -0400] - Failed to start object plugin
>> Multimaster Replication Plugin
>> [25/Sep/2012:13:29:03 -0400] - Error: Failed to resolve plugin
>> dependencies
>> [25/Sep/2012:13:29:03 -0400] - Error: preoperation plugin IPA Version
>> Replication is not started
>> [25/Sep/2012:13:29:03 -0400] - Error: object plugin Legacy Replication
>> Plugin is not started
>> [25/Sep/2012:13:29:03 -0400] - Error: object plugin Multimaster
>> Replication Plugin is not started
>> [25/Sep/2012:13:37:37 -0400] - 389-Directory/1.2.10.14 B2012.201.358
>> starting up
>> [25/Sep/2012:13:37:37 -0400] - Detected Disorderly Shutdown last time
>> Directory Server was running, recovering database.
>> [25/Sep/2012:13:37:40 -0400] - Skipping CoS Definition cn=Password
>> Policy,cn=accounts,dc=ecg,dc=mit,dc=edu--no CoS Templates found, which
>> should be added before the CoS Definition.
>> [25/Sep/2012:13:37:41 -0400] NSMMReplicationPlugin - changelog program
>> - cl5DBData2Entry: invalid data version
>> [25/Sep/2012:13:37:41 -0400] NSMMReplicationPlugin - changelog program
>> - cl5Open: failed to open changelog
>> [25/Sep/2012:13:37:41 -0400] NSMMReplicationPlugin - changelog program
>> - changelog5_init: failed to start changelog at
>> /var/lib/dirsrv/slapd-ECG-MIT-EDU/cldb
>> [25/Sep/2012:13:37:42 -0400] - Failed to start object plugin
>> Multimaster Replication Plugin
>> [25/Sep/2012:13:37:43 -0400] NSMMReplicationPlugin - changelog program
>> - cl5DBData2Entry: invalid data version
>> [25/Sep/2012:13:37:43 -0400] NSMMReplicationPlugin - changelog program
>> - cl5Open: failed to open changelog
>> [25/Sep/2012:13:37:43 -0400] NSMMReplicationPlugin - changelog program
>> - changelog5_init: failed to start changelog at
>> /var/lib/dirsrv/slapd-ECG-MIT-EDU/cldb
>> [25/Sep/2012:13:37:43 -0400] - Failed to start object plugin
>> Multimaster Replication Plugin
>> [25/Sep/2012:13:37:43 -0400] - Error: Failed to resolve plugin
>> dependencies
>> [25/Sep/2012:13:37:43 -0400] - Error: preoperation plugin IPA Version
>> Replication is not started
>> [25/Sep/2012:13:37:43 -0400] - Error: object plugin Legacy Replication
>> Plugin is not started
>> [25/Sep/2012:13:37:43 -0400] - Error: object plugin Multimaster
>> Replication Plugin is not started
>>
>> We've been through Rich's suggested procedure to manually initialize
>> the consumer, but still get the message above.
>>
>> Any ideas?
>
> Assuming the directory server is not running, do this:
> rm -rf /var/lib/dirsrv/slapd-ECG-MIT-EDU/cldb
> then follow the ldif2db procedure
> then start the directory server
>
>>
>> Thanks,
>>
>> Dan
>>
>>
>> On Mon, Sep 24, 2012 at 10:26 AM, Alexander Bokovoy<aboko...@redhat.com>
>> wrote:
>>>
>>> On Mon, 24 Sep 2012, Ikaro Silva wrote:
>>>>
>>>> Hi Rich,
>>>>
>>>> Thanks for the help. We have tried  your suggestion below, however the
>>>> problem still persists:
>>>>
>>>> systemctl status dirsrv.service
>>>
>>> There is no dirsrv.service. dirsrv instances are arranged in
>>> following setup:
>>>
>>> - there is dirsrv.target that is used to start and stop all instances at
>>>    the same time
>>>
>>> - there are dirsrv@INSTANCE-NAME.service services for specific instances
>>>    where INSTANCE-NAME is REALM with dots replaced by -.
>>>
>>> IPA currently operates on two dirsrv instances (PKI-CA and REALM). If you
>>> want to
>>> start/stop them all, use
>>>
>>> systemctl stop dirsrv.target
>>> systemctl start dirsrv.target
>>>
>>> For status you need to check specific instances.
>>>
>>> systemctl status dirsrv@<REALM>.service
>>>
>>> # systemctl status dirsrv@IPA-LOCAL.service
>>> dirsrv@IPA-LOCAL.service - 389 Directory Server IPA-LOCAL.
>>>            Loaded: loaded (/lib/systemd/system/dirsrv@.service; enabled)
>>>            Active: active (running) since Mon, 24 Sep 2012 11:53:04
>>> +0300; 5h
>>> 31min ago
>>>           Process: 684 ExecStart=/usr/sbin/ns-slapd -D
>>> /etc/dirsrv/slapd-%i
>>> -i /var/run/dirsrv/slapd-%i.pid -w /var/run/dirsrv/slapd-%i.startpid
>>> (code=exited, status=0/SUCCESS)
>>>          Main PID: 688 (ns-slapd)
>>>            CGroup: name=systemd:/system/dirsrv@.service/IPA-LOCAL
>>>                    └ 688 /usr/sbin/ns-slapd -D
>>> /etc/dirsrv/slapd-IPA-LOCAL -i
>>> /var/run/dirsrv/slapd-IPA-LOCAL.pid -w /var/run/dirs...
>>>
>>>
>>>> dirsrv.service
>>>>           Loaded: error (Reason: No such file or directory)
>>>>           Active: inactive (dead)
>>>> [root@fileserver2 ~]#  ipactl status
>>>> Directory Service: STOPPED
>>>> Unknown error when retrieving list of services from LDAP: [Errno 111]
>>>> Connection refused
>>>>
>>>>
>>>> Any other suggestions/advice would be greatly appreaciated.
>>>>
>>>> Thank you,
>>>>
>>>> -Ikaro
>>>>
>>>> On Thu, Sep 20, 2012 at 10:59 AM, Rich Megginson<rmegg...@redhat.com>
>>>> wrote:
>>>>>
>>>>> On 09/20/2012 08:53 AM, Ikaro Silva wrote:
>>>>>>
>>>>>>
>>>>>> Hi Rich,
>>>>>>
>>>>>> We did not upgrade from a previous version, this is our original
>>>>>> master server (but we do have 2 other replications of this one). The
>>>>>> architecture is
>>>>>>
>>>>>> Linux 3.4.9-2.fc16.i686.PAE #1 SMP Thu Aug 23 18:41:34 UTC 2012 i686
>>>>>> i686 i386 GNU/Linux
>>>>>
>>>>>
>>>>> ok - try this:
>>>>>
>>>>>
>>>>> https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Directory_Server/9.0/html/Administration_Guide/Managing_Replication-Initializing_Consumers.html#Initializing_Consumers-Manual_Consumer_Initialization_Using_the_Command_Line
>>>>>
>>>>> you will need to use db2ldif.pl -r to create a replica init ldif file
>>>>> from
>>>>> one of your good replicas, copy this file to the machine with the "bad"
>>>>> replica, and use ldif2db to reinitialize it.
>>>>>
>>>>> You use db2ldif.pl on the replica because you can perform this
>>>>> operation
>>>>> while the server is running.
>>>>>
>>>>> You use ldif2db on the bad replica because you can't start the server.
>>>>>
>>>>> Note that due to selinux restrictions, you have to use
>>>>> /var/lib/dirsrv/slapd-DOMAIN/ldif as the export and import directory.
>>>>>
>>>>>>
>>>>>>
>>>>>> On Thu, Sep 20, 2012 at 10:16 AM, Rich Megginson<rmegg...@redhat.com>
>>>>>> wrote:
>>>>>>>
>>>>>>>
>>>>>>> On 09/20/2012 08:10 AM, Ikaro Silva wrote:
>>>>>>>>
>>>>>>>>
>>>>>>>> Hi Everyone,
>>>>>>>>
>>>>>>>>
>>>>>>>> I am new to IPA and I am trying to start the IPA service but I get
>>>>>>>> the
>>>>>>>> following error message:
>>>>>>>>
>>>>>>>> ipactl start
>>>>>>>> Starting Directory Service
>>>>>>>> Failed to read data from Directory Service: Unknown error when
>>>>>>>> retrieving list of services from LDAP: [Errno 111] Connection
>>>>>>>> refused
>>>>>>>> Shutting down
>>>>>>>
>>>>>>>
>>>>>>> What platform?  Did you upgrade from a previous version?
>>>>>>> Do you have another master that you could use to reinit this one
>>>>>>> from?
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> When I cat the /var/log/dirsrv/slapd-ECG-MIT-EDU/errors I get the
>>>>>>>> following messages:
>>>>>>>>
>>>>>>>> [20/Sep/2012:10:08:53 -0400] - 389-Directory/1.2.10.14 B2012.201.358
>>>>>>>> starting up
>>>>>>>> [20/Sep/2012:10:08:54 -0400] - Detected Disorderly Shutdown last
>>>>>>>> time
>>>>>>>> Directory Server was running, recovering database.
>>>>>>>> [20/Sep/2012:10:08:57 -0400] - Skipping CoS Definition cn=Password
>>>>>>>> Policy,cn=accounts,dc=ecg,dc=mit,dc=edu--no CoS Templates found,
>>>>>>>> which
>>>>>>>> should be added before the CoS Definition.
>>>>>>>> [20/Sep/2012:10:08:58 -0400] NSMMReplicationPlugin - changelog
>>>>>>>> program
>>>>>>>> - cl5DBData2Entry: invalid data version
>>>>>>>> [20/Sep/2012:10:08:58 -0400] NSMMReplicationPlugin - changelog
>>>>>>>> program
>>>>>>>> - cl5Open: failed to open changelog
>>>>>>>> [20/Sep/2012:10:08:58 -0400] NSMMReplicationPlugin - changelog
>>>>>>>> program
>>>>>>>> - changelog5_init: failed to start changelog at
>>>>>>>> /var/lib/dirsrv/slapd-ECG-MIT-EDU/cldb
>>>>>>>> [20/Sep/2012:10:08:58 -0400] - Failed to start object plugin
>>>>>>>> Multimaster Replication Plugin
>>>>>>>> [20/Sep/2012:10:08:59 -0400] NSMMReplicationPlugin - changelog
>>>>>>>> program
>>>>>>>> - cl5DBData2Entry: invalid data version
>>>>>>>> [20/Sep/2012:10:08:59 -0400] NSMMReplicationPlugin - changelog
>>>>>>>> program
>>>>>>>> - cl5Open: failed to open changelog
>>>>>>>> [20/Sep/2012:10:08:59 -0400] NSMMReplicationPlugin - changelog
>>>>>>>> program
>>>>>>>> - changelog5_init: failed to start changelog at
>>>>>>>> /var/lib/dirsrv/slapd-ECG-MIT-EDU/cldb
>>>>>>>> [20/Sep/2012:10:08:59 -0400] - Failed to start object plugin
>>>>>>>> Multimaster Replication Plugin
>>>>>>>> [20/Sep/2012:10:08:59 -0400] - Error: Failed to resolve plugin
>>>>>>>> dependencies
>>>>>>>> [20/Sep/2012:10:08:59 -0400] - Error: preoperation plugin IPA
>>>>>>>> Version
>>>>>>>> Replication is not started
>>>>>>>> [20/Sep/2012:10:08:59 -0400] - Error: object plugin Legacy
>>>>>>>> Replication
>>>>>>>> Plugin is not started
>>>>>>>> [20/Sep/2012:10:08:59 -0400] - Error: object plugin Multimaster
>>>>>>>> Replication Plugin is not started
>>>>>>>>
>>>>>>>>
>>>>>>>> Has anyone experienced similar problems or have suggestions on how
>>>>>>>> to
>>>>>>>> fix these errors ?
>>>>>>>>
>>>>>>>>
>>>>>>>> Thank you,
>>>>>>>>
>>>>>>>> -Ikaro
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> Freeipa-users mailing list
>>>>>>>> Freeipa-users@redhat.com
>>>>>>>> https://www.redhat.com/mailman/listinfo/freeipa-users
>>>>>>>
>>>>>>>
>>>>>>>
>>>> _______________________________________________
>>>> Freeipa-users mailing list
>>>> Freeipa-users@redhat.com
>>>> https://www.redhat.com/mailman/listinfo/freeipa-users
>>>
>>>
>>>
>>>
>>> --
>>> / Alexander Bokovoy
>>>
>>>
>>> _______________________________________________
>>> Freeipa-users mailing list
>>> Freeipa-users@redhat.com
>>> https://www.redhat.com/mailman/listinfo/freeipa-users
>>
>> _______________________________________________
>> Freeipa-users mailing list
>> Freeipa-users@redhat.com
>> https://www.redhat.com/mailman/listinfo/freeipa-users
>
>



-- 
Ikaro Silva, Ph.D.
ik...@mit.edu
Harvard-MIT Division of Health Sciences and Technology
MIT Room E25-505,
Cambridge, MA 02139 USA

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to