Simon Williams wrote:

I ran a yum update on my CentOS 6 server that runs FreeIPA a couple of
days ago and it upgraded FreeIPA to version 3. I use a couple of web
applications that cannot use Kerberos, but can use LDAP to
authenticate.  These stopped working. When I investigated the issue, I
discovered that the LDAP server wasn't there any more. Google searches
have proved fruitless and I can't find any documentation for v3. Can
anyone tell me how to get my LDAP server back?

There is a bug in 389-ds that is affecting some IPA upgrades. It causes the upgrade process to hang and breaking out of it leaves the LDAP server not listening to anything (note that if the upgrade outright fails we do restore things).

What you want to do is this:

1. service dirsrv stop (you MUST do this before editing dse.ldif)
2. edit dse.ldif and set
nsslapd-port: 389
nsslapd-security: on
3. service dirsrv start
4. as root, ipa-ldap-updater --ldapi

Updated 389-ds packages are being worked on.


Freeipa-users mailing list

Reply via email to