On 05/02/2013 03:49 PM, Lager, Nathan T. wrote:
I have an IPA server that i'm rebuilding.  It was part of a 3 server 
replication.  That is, three ipa replicas. Caroline0 through 2.

I have the server rebuilt, the problem is, it wasn't cleanly removed from the 
ipa replication in the first place, so the other two replicas still think it 
exists.  I thought it should be a simple matter of deleting the down replica on 
the other two, but thats not working out.

Yes, I understand that it should have been cleanly uninstalled, and that would 
have avoided this.  Live and learn.

Here's some detail. Caroline1 is the server which is to be rebuilt.

[root@caroline2 PROD ~]# ipa-replica-manage list
caroline0.lafayette.edu: master
caroline2.lafayette.edu: master
caroline1.lafayette.edu: master
[root@caroline2 PROD ~]# ipa-replica-manage del caroline1.lafayette.edu
'caroline2.lafayette.edu' has no replication agreement for 
'caroline1.lafayette.edu'
[root@caroline2 PROD ~]# ipa host-del caroline1.lafayette.edu
ipa: ERROR: invalid 'hostname': An IPA master host cannot be deleted or disabled

I have tried the same commands from Caroline0, which is the first ipa server i 
built, thinking that maybe it was in some way authoritative in some matters 
because it was the first. Same deal there.

I've tried simply re-adding my rebuilt caroline1, hoping it would replace the 
old, no luck there.

The host caroline1.lafayette.edu already exists on the master server.
You should remove it before proceeding:
     % ipa host-del caroline1.lafayette.edu

I think the key here is to convince the other two ipa servers, that caroline1 
is no longer a master, but I haven't found a way to do that yet.

Use the --force:

ipa-replica-manage del --force caroline1.lafayette.edu

The command tries severs replication agreements before deleting info about the replica. With --force it will ignore the fact that there's no agreement and continue on.

--
PetrĀ³

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to