On 07/16/2013 07:24 PM, Armstrong, Kenneth Lawrence wrote:
Hello all,

i have a new problem with the SSH Key bit in the web interface.  I created a 
new ssh key for a user, and pasted it into the web interface for the user.  
Afterward, it said that the key was not set.  So I attempted again from the 
commandline, and it looks like it took it.  However, when I go back to the web 
interface, it doesn't show one set for the user.

I logged out of the interface and back in, but same story.

Running IPA server 3.0 on RHEL 6.4.

Any thoughts?

-Kenny


Hello Kenny,

When SSH Public keys field in Web UI displays: "New: key not set" it means that the key was not set in 'Show/Set key' dialog. In other words you did not paste anything into the textarea or you pressed 'Cancel' button instead of 'Set' button.

If something is pasted and confirmed by 'Set' button it displays: 'New: key set'. The last remaining step is to click on 'Update' button on the header part of the page to confirm and perform all the changes you made on the page.

When keys are set in LDAP you should see a line similar to following for each key:
"13:67:6B:BF:4E:A2:05:8E:AE:25:8B:A1:31:DE:6F:1B public key test (ssh-rsa)"
Each fingerprint is followed by 'Show/Set key' and 'Delete' buttons.

I can't comment the CLI part without more information: key and exact command you used.

HTH
--
Petr Vobornik

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to