On 20/07/13 02:07, Ade Lee wrote:

Sorry for the late response.  Just saw this email.


No problem :-)

I'm surprised that you were able to update your machine to F19.  We
explicitly put in spec file logic to do a pre-trans check to see if you
had dogtag 9 system instances before updating to f19.  This was to
prevent people from getting into a situation where there installation
was broken.

I updated through yum, which I know isn't "officially" supported but it's always worked well since the FC1 days. The RPM scripts did fail on the dogtag RPM I believe but it doesn't prevent the complete yum transaction from running, just that RPM fails to update. I saw the error message in the output pointing to the wiki page I posted.

The issue is that dogtag 9 instances use tomcat 6, and tomcat 6 is no
longer in fedora 19.  Dogtag 10 instances, on the other hand, use tomcat
7.  The two instance types are therefore incompatible.

The Wiki page explained the reasons quite well, but I found the descriptions of what to do to fix the situation lacking in detail for somebody who's not an expert with IPA. Hence the post.

The suggestion therefore would have been to create a replica of the ipa
master prior to doing the upgrade to F19.  In fact, you could have just
installed a brand new f19 machine and then created a replica (and then
shut down the old machine).

True I could have done that, but as this is for home use the actual contents in the directory were small, so I just found it easier to blow away the current install and set it up again. Obviously I wouldn't do that in a production environment but I wouldn't be using/upgrading Fedora either. The server it's installed on does a lot more than FreeIPA anyway. I'm considering setting up a replica in a VM so that I can check/test updates in the future before touching the master.

Seeing as you have somehow upgraded your machine to F19, we need to try
and get your system back up.  For that, you need to follow the
instructions in "Workaround" ie. installing tomcat6 and downgrading
tomcatjss to the version in f18.  That will hopefully get your CA up and
running.  At that point, it is highly recommended that you use ipa
utilities to create a replica and use that instead.

Actually I believe tomcat6 remained installed from F18 - it wasn't upgraded or removed. Tomcatjss did get upgraded but I tried downgrading to the version from Fedora 18 and still had issues. A couple of days went by so I decided to reinstall it. Thanks for replying though Ade :-)

--
Ian Chapman.

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to