On Thu, Oct 03, 2013 at 05:02:44PM -0400, Dmitri Pal wrote:
> On 09/27/2013 08:13 AM, Ade wrote:
> > I have a dirsrv server using the slapi-nis plugin to provide 190+ nis
> > maps. It works well apart from one issue - boot up
> >
> > If I do a reboot, the dirsrv starts up ok, but slapi-nis doesnt seem
> > to register to rpc - logging in and restarting dirsrv fixes it
> >
> > I tried disabling dirsrv and putting a start into rc.local - exactly the 
> > same
> >
> > I tried disabling dirsrv and putting a start into rc.local with a
> > sleep 120 first, and this works !!
> >
> > So it seems like it needs something to startup and settle first - any
> > ideas?   I can see that rpcbind starts before dirsrv. I even wrote a
> > small script that waits for rpcinfo -p to return non zero before
> > continuing to start dirsrv - didnt work
> 
> Did anyone reply?

Not on the list, but given the sender, I think he found me elsewhere,
and we debugged it.

> Was the problem solved?

Yes, it should be fixed in slapi-nis 0.50.  That version reconnects to
rpcbind if rpcbind has dropped the connection from the plugin since the
plugin last connected to rpcbind (the plugin connects first before the
server drops privileges, then after the server drops privileges, it
computes the contents of map entries, and it only sends the registration
request to rpcbind once it's ready to answer client queries).

It turns out some RPC libraries (which rpcbind links with) will
disconnect clients which they consider to be "idle" after some period,
and that was biting us because computing map contents was taking more
than that length of time, in part because the search filter that was
used to select entries for use in populating NIS maps was referring to
attributes that weren't indexed.

Nalin

_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to