That is right, I forgot about adding those options.

So what I did was stopped ypserv (since the IPA plugin functions should handle 
all incoming NIS requests right?)
Restarted the dirsrv and rpcbind.

I try running ypbind on both the server and client but it fails with the same 
error.

I tried running ypcat from a client and it gives the following error;

No such map passwd.byname: Reason: Can't communicate with portmapper.

So I checked port 1023 (ns-slapd is running) and nothing else is using port 
1023.

I restarted dirsrv and rpcbind 2 times each and then it finally worked.
I'm going to try to reboot the server at the earliest time possible to make 
sure the config sticks.

Thank you for the help guys and helping me understand how the NIS module in IPA 
works.

Matt


-----Original Message-----
From: Rob Crittenden [mailto:rcrit...@redhat.com] 
Sent: Tuesday, January 07, 2014 11:36 AM
To: Nalin Dahyabhai; Joseph, Matthew (EXP)
Cc: freeipa-users@redhat.com
Subject: Re: [Freeipa-users] EXTERNAL: Re: NIS Compat issues

Nalin Dahyabhai wrote:
> On Tue, Jan 07, 2014 at 05:22:22AM -0500, Joseph, Matthew (EXP) wrote:
>> When I run ypcat on the IPA servers it states that ypbind can't communicate.
>> I started ypbind on the secondary IPA server so now I can run ypcat.
>> Is running ypbind on the IPA servers necessary? According to all of the 
>> documentation I read it doesn't mention anything about ypbind on the servers.
>
> Any system on which you intend to run ypcat, ypmatch, or any of the NIS
> client commands should run ypbind, whether it's talking to a more
> traditional NIS server or an IPA server with its NIS service enabled.
>

I run ypcat w/o ypbind all the time for testing. You just need to 
specify the server and domain on the command-line:

$ ypcat -h `hostname` -d example.com passwd

rob


_______________________________________________
Freeipa-users mailing list
Freeipa-users@redhat.com
https://www.redhat.com/mailman/listinfo/freeipa-users

Reply via email to