Hi James,

On Thu, 24 Jul 2014, James James wrote:

The files are in attachment.
Thanks for you help.
2014-07-24 9:41 GMT+02:00 Jakub Hrozek <jhro...@redhat.com>:
On Wed, Jul 23, 2014 at 11:45:28PM +0200, James James wrote:
HI guy, I've been struggling for a while tom make sssd works with autofs . I have a freeipa server that serves maps. When a client is enrolled and I make in a terminal [...]
Can you attach your config file and check out what's in
/var/log/sssd/sssd_autofs.log once you add debug_level=6 into the
[autofs] section?

you may want to try the following:

1. Add

---
[sssd]
...
ldap_autofs_search_base="dc=example,dc=com""
---

in your sssd.conf

2. Your /etc/sysconfig/autofs appears to be missing some entries. Mine contains

---
AUTOFS_OPTIONS=""
LOCAL_OPTIONS=""
APPEND_OPTIONS="no"
USE_MISC_DEVICE="yes"
DEFAULT_MASTER_MAP_NAME="auto.master"
DEFAULT_TIMEOUT=300
DEFAULT_BROWSE_MODE="no"
DEFAULT_LOGGING="none"
DEFAULT_MAP_OBJECT_CLASS="automountMap"
DEFAULT_ENTRY_OBJECT_CLASS="automount"
DEFAULT_MAP_ATTRIBUTE="automountMapName"
DEFAULT_ENTRY_ATTRIBUTE="automountKey"
DEFAULT_VALUE_ATTRIBUTE="automountInformation"
DEFAULT_AUTH_CONF_FILE=""
MAP_HASH_TABLE_SIZE=1024
SEARCH_BASE="cn=[automountlocation_as_defined_in_ipa],cn=automount,dc=example,dc=com"
LDAP_URI="ldap:///dc=example,dc=com";
---

3. I had to put "ldap" instead of "sss" in nsswitch.conf like so:

---
--- nsswitch.conf       2014-07-24 10:30:59.207122633 +0200
+++ nsswitch.conf.orig  2014-07-24 10:30:36.417245012 +0200
@@ -61,7 +61,7 @@

 publickey:  nisplus

-automount: ldap files
+automount: sss files

 aliases:    files nisplus
---

My client system is openSUSE 13.1


Mit freundlichen Gruessen/With best regards,

--Daniel.

--
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go To http://freeipa.org for more info on the project

Reply via email to