Curtis L. Knight wrote:
> On Tue, Aug 5, 2014 at 7:21 AM, Martin Kosek <mko...@redhat.com
> <mailto:mko...@redhat.com>> wrote:
> 
>     On 08/05/2014 12:32 PM, Martin Kosek wrote:
>     > On 08/05/2014 12:05 PM, Curtis L. Knight wrote:
>     ...
>     >> #./make-lint $(LINT_OPTIONS)
>     >>
>     >> run 'make rpms' again to get beyond lint errors shown below
>     >>
>     >>
>     >> cd install; if [ ! -e Makefile ]; then ../autogen.sh --prefix=/usr
>     >> --sysconfdir=/etc --localstatedir=/var --libdir=/usr/lib; fi
>     >> ./make-lint
>     >> Traceback (most recent call last):
>     >>   File "./make-lint", line 272, in <module>
>     >>     sys.exit(main())
>     >>   File "./make-lint", line 243, in main
>     >>     linter.check(files)
>     >>   File "/usr/lib/python2.7/site-packages/pylint/lint.py", line
>     626, in check
>     >>     self.check_astroid_module(astroid, walker, rawcheckers,
>     tokencheckers)
>     >>   File "/usr/lib/python2.7/site-packages/pylint/lint.py", line
>     712, in
>     >> check_astroid_module
>     >>     walker.walk(astroid)
>     >>   File "/usr/lib/python2.7/site-packages/pylint/utils.py", line
>     715, in walk
>     >>     self.walk(child)
>     >>   File "/usr/lib/python2.7/site-packages/pylint/utils.py", line
>     715, in walk
>     >>     self.walk(child)
>     >>   File "/usr/lib/python2.7/site-packages/pylint/utils.py", line
>     712, in walk
>     >>     cb(astroid)
>     >>   File
>     "/usr/lib/python2.7/site-packages/pylint/checkers/newstyle.py",
>     >> line 135, in visit_function
>     >>     args=(call.args[0].name, ))
>     >> AttributeError: 'Getattr' object has no attribute 'name'
>     >> make: *** [lint] Error 1
>     >
>     > This is new, I created upstream ticket to timely fix it:
>     > https://fedorahosted.org/freeipa/ticket/4475
> 
>     Ticket 4475 is now fixed, thanks to Jan Cholasta. ipa-3-3 branch
>     should now
>     build OK again.
> 
>     Martin
> 
> 
> Hey Martin,
> 
> Tested ipa-3-3 and generated rpms from that branch. Many thanks for the
> resolution.
> 
> Just a note, but I verified that ipa-3-2 and ipa-3-1 are in need of the
> same ipa-3-3 dependency patch. Both also complained that make-lint
> needed pylint installed which it already was. With the lint failure and
> rhino patch, ipa-3-2 did generate rpms. With the lint failure and rhino
> patch, ipa-3-1 did not generate rpms and gave the following logs.

I guess it becomes a bit fuzzy, especially with these versions. We don't
usually offer any guarantees that older releases will build against more
modern distros, but both 3.1.5 and 3.2.0 crossed that line, with Fedora
builds in two releases (F18/19 and F19/20 respectively).

Do you have a requirement to use these older releases or are you just
offering this data point in case anyone else runs into this?

regards

rob

-- 
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go To http://freeipa.org for more info on the project

Reply via email to