Thanks for your responses Alexander, Dimitri and Gerardo. It appears
further debugging will be unnecessary: I reinstalled on RHEL 7 and the
trust established without issue:


----
[root@kwtpocidm001 ~]# ipa trust-add --type=ad mhatest.local --admin
Administrator --password
Active directory domain administrator's password:
------------------------------------------------------
Added Active Directory trust for realm "MHATEST.LOCAL"
------------------------------------------------------
  Realm name: MHATEST.LOCAL
  Domain NetBIOS name: MHATEST
  Domain Security Identifier: S-1-5-21-2226261992-3934846357-352671753
  SID blacklist incoming: S-1-0, S-1-1, S-1-2, S-1-3, S-1-5-1, S-1-5-2,
S-1-5-3, S-1-5-4, S-1-5-5, S-1-5-6, S-1-5-7, S-1-5-8, S-1-5-9, S-1-5-10,
                          S-1-5-11, S-1-5-12, S-1-5-13, S-1-5-14, S-1-5-15,
S-1-5-16, S-1-5-17, S-1-5-18, S-1-5-19, S-1-5-20
  SID blacklist outgoing: S-1-0, S-1-1, S-1-2, S-1-3, S-1-5-1, S-1-5-2,
S-1-5-3, S-1-5-4, S-1-5-5, S-1-5-6, S-1-5-7, S-1-5-8, S-1-5-9, S-1-5-10,
                          S-1-5-11, S-1-5-12, S-1-5-13, S-1-5-14, S-1-5-15,
S-1-5-16, S-1-5-17, S-1-5-18, S-1-5-19, S-1-5-20
  Trust direction: Two-way trust
  Trust type: Active Directory domain
  Trust status: Established and verified
[root@kwtpocidm001 ~]#
----


Now onto the next hurdle :-)



On Thu, Sep 11, 2014 at 12:31 AM, Alexander Bokovoy <aboko...@redhat.com>
wrote:

> On Thu, 11 Sep 2014, Traiano Welcome wrote:
>
>> Hi List
>>
>> I've been following the AD integration guide for IPAv3 here:
>> http://www.freeipa.org/page/Howto/IPAv3_AD_trust_setup
>> However, when I reach the "Add trust with AD domain" step I get the
>> following error:
>>
>> ---
>> [root@ipa ~]# ipa trust-add --type=ad mhatest.local --admin Administrator
>> --password
>> Active directory domain administrator's password:
>> ipa: ERROR: CIFS server communication error: code "-1073741801",
>>                  message "Memory allocation error" (both may be "None")
>> ---
>>
>> ... And I'm at a loss for how to interpret this :-) Details on my setup:
>>
> Please follow
> http://www.freeipa.org/page/Howto/IPAv3_AD_trust_setup#Debugging_trust
> to provide useful debugging information.
>
>  - Windows 2008 R2 AD DC
>> - CentOS Linux 6.5 IPA server (installed  from yum repos)
>>
> Ideally you'd need to use RHEL 7 or CentOS 7 for trusts as IPA version
> 3.3 is more mature in this regard.
>
> --
> / Alexander Bokovoy
>
-- 
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go To http://freeipa.org for more info on the project

Reply via email to