On (14/10/14 16:03), Fraser Tweedale wrote:
>On Mon, Oct 13, 2014 at 10:08:55PM -0700, Janelle wrote:
>> Actually, I did find a fix and forgot to post.
>> 
>> I was able to mirror the COPR repo, and after reviewing it, found that
>> simply removing the pki-base...fc21 directory, and regenning the repo data
>> with createrepo, fixed the problem. It drops the version of PKI back to the
>> 10.1 branch and that resolved the dependencies.
>> 
>> Hope this helps,
>> Janelle
>> 
>
>Glad you were able to find a fix.  Of course, we will still need to
>fix the 10.2 build, so thanks for reporting!

If dogtag team adds new dependency you will not be able to fix 10.2 build.
I am able to install pki-base-10.2 on fedora 21 without any problem.
So ther isn't problem in pki-base.

The problem is with backporting pki-base to el7.
The package jackson-jaxrs-json-provider should be backported to el7 as well.
(or someone should package jackson-jaxrs-json-provider in epel7)

If we don't want to have the latest packages from fedora in COPR repo then
the other option is to have minimal required version of packages in COPR repo.
It would reduce count of backported packages.

LS

-- 
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go To http://freeipa.org for more info on the project

Reply via email to