On 03/27/2015 11:32 AM, Sankar Ramlingam wrote:
On 03/27/2015 01:42 PM, David Kreuter wrote:
No, there are no entries with "segfaulter" neither in /var/log/messags nor in journalctr.


Meanwhile we encountered several directory server hangs and I was able to produce the stacktrace. Perhpas you can have a look.
Hi David,
You seem to have the latest/released version of 389-ds-base. You can probably try an upgrade to get the latest of other dependent components and 389-ds-base-debuginfo.

Yes. Please add this package and try to capture the stack trace again.
We will then be able to see where the issue is.


Thanks,
-Sankar R.


------------------------------------------------------------------------
*From: *"David Kreuter" <david.kreu...@bytesource.net>
*To: *"freeipa-users" <freeipa-users@redhat.com>
*Sent: *Thursday, 26 March, 2015 11:18:59 PM
*Subject: *Unexpected IPA Crashes

We have been using FreeIPA since two years and were more than happy. But since two weeks we are facing unexpected crashed and can not really debug the strange behaviours. The crashes are definitely not caused by connecting a new system or changing the LDAP schema heavily. Following IPA is used:

Name        : ipa-server

Arch        : x86_64

Version     : 3.3.3

Release     : 28.0.1.el7.centos.3

Size        : 4.1 M


I have followed the troubleshooting guide http://directory.fedoraproject.org/docs/389ds/FAQ/faq.html#Troubleshooting and activated logging and activated the core dumping. Unfortunately, I cannot provide you any core dump, because it is not created after the ipa servers crashes. I'm sure the dirsrv is causing the problem, because when i restart the 389, then ipa works fine for a while. Currently I have activated the replication log level 8192. The error log shows no suspicious error or any fatal error. Following 389* versions are used:


Installed Packages

389-ds-base.x86_64 1.3.3.1-15.el7_1 @/389-ds-base-1.3.3.1-15.el7_1.x86_64

389-ds-base-debuginfo.x86_64 1.3.1.6-26.el7_0       @base-debuginfo

389-ds-base-libs.x86_64 1.3.3.1-15.el7_1


Can you please provide some hint how I can debug this problem in more detail. Btw, the ipa infrastructure consist of one master and one replica. The server was also crashing, when the replica server was turned off. Do you thing an upgrade would solve the problem as the last resort?










--
Thank you,
Dmitri Pal

Sr. Engineering Manager IdM portfolio
Red Hat, Inc.

-- 
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to