On 02/04/15 12:53, Winfried de Heiden wrote:
Hi all,

"Because I can try" I gave a shot on installing freeipa-server on a Raspberry Pi 2. I used Fedora 21 for this. Installing looks promising, but fails somewhere halfway:

      [8/27]: starting certificate server instance
      [error] RuntimeError: CA did not start in 300.0s
    CA did not start in 300.0s


and the install log will tell:

    [root@ipa log]# tail /var/log/ipaserver-install.log
      File
    "/usr/lib/python2.7/site-packages/ipaserver/install/service.py",
    line 279, in start
        self.service.start(instance_name,
    capture_output=capture_output, wait=wait)

      File
    "/usr/lib/python2.7/site-packages/ipaplatform/redhat/services.py",
    line 229, in start
        self.wait_until_running()

      File
    "/usr/lib/python2.7/site-packages/ipaplatform/redhat/services.py",
    line 223, in wait_until_running
        raise RuntimeError('CA did not start in %ss' % timeout)

    2015-04-02T09:58:36Z DEBUG The ipa-server-install command failed,
    exception: RuntimeError: CA did not start in 300.0s


I 'm wondering if this is a timing issue... Of course the Pi2 tends to be slow and no wonder starting things will takes "some time"... (Yep, I 'm trying to move tons of stones using only a 2CV car...) The catalina log (that's the CA (Tomcat) log right?)
tells it needs some more time to start:

    [root@ipa pki-tomcat]# tail
    /var/log/pki/pki-tomcat/catalina.2015-04-02.log
    Apr 02, 2015 11:59:20 AM org.apache.catalina.startup.HostConfig
    deployDescriptor
    INFO: Deployment of configuration descriptor
    /etc/pki/pki-tomcat/Catalina/localhost/ROOT.xml has finished in
    84,815 ms
    Apr 02, 2015 11:59:20 AM org.apache.coyote.AbstractProtocol start
    INFO: Starting ProtocolHandler ["http-bio-8080"]
    Apr 02, 2015 11:59:20 AM org.apache.coyote.AbstractProtocol start
    INFO: Starting ProtocolHandler ["http-bio-8443"]
    Apr 02, 2015 11:59:20 AM org.apache.coyote.AbstractProtocol start
    INFO: Starting ProtocolHandler ["ajp-bio-127.0.0.1-8009"]
    Apr 02, 2015 11:59:20 AM org.apache.catalina.startup.Catalina start
    INFO: Server startup in 355603 ms

Anyone got an idea how to set the time out for the CA to start to 10 or 15 minuten? Any other sugestion what is causing this problem? (no, I am not upgrading from an older version, this is a fresh install)

Kind regards,

Winfried




Hello,
you can try:

https://www.redhat.com/archives/freeipa-users/2015-April/msg00076.html



--
Martin Basti

-- 
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to