On 04/15/2015 12:43 PM, James James wrote:
Here the log

2015-04-15 18:58 GMT+02:00 Rich Megginson <rmegg...@redhat.com <mailto:rmegg...@redhat.com>>:

    On 04/15/2015 09:46 AM, James James wrote:
    Hello,

    I have been looking to solve my problem but I 'm asking for some
    help.

    The replication begins but cannot be completed ....

    I want to install a new fresh replica but I've always got this
    error :

    [21/35]: configure dirsrv ccache
      [22/35]: enable SASL mapping fallback
      [23/35]: restarting directory server
      [24/35]: setting up initial replication
    Starting replication, please wait until this has completed.
    Update in progress, 127 seconds elapsed
    Update in progress yet not in progress

    Update in progress yet not in progress

    [ipa.example.com <http://ipa.example.com>] reports: Update
    failed! Status: [10 Total update abortedLDAP error: Referral]

      [error] RuntimeError: Failed to start replication

    Your system may be partly configured.
    Run /usr/sbin/ipa-server-install --uninstall to clean up.

    Failed to start replication


    On the master I have this message :
    15/Apr/2015:15:57:37 +0200] NSMMReplicationPlugin - CleanAllRUV
    Task: Successfully cleaned rid(19).
    [15/Apr/2015:17:06:32 +0200] NSMMReplicationPlugin -
    agmt="cn=meToipa1.example.com <http://meToipa1.example.com>"
    (ipa1:389): Replica has a different generation ID than the local
    data.
    [15/Apr/2015:17:06:33 +0200] NSMMReplicationPlugin - Beginning
    total update of replica "agmt="cn=meToipa1.example.com
    <http://meToipa1.example.com>" (ipa1:389)".

    What is happening on the consumer (ipa1.example.com
    <http://ipa1.example.com>) error and access log at this time?


[15/Apr/2015:17:06:33 +0200] NSMMReplicationPlugin - multimaster_be_state_change: replica dc=lix,dc=polytechnique,dc=fr is going offline; disabling replication [15/Apr/2015:17:06:33 +0200] - WARNING: Import is running with nsslapd-db-private-import-mem on; No other process is allowed to access the database [15/Apr/2015:17:06:53 +0200] - import userRoot: Processed 1399 entries -- average rate 70.0/sec, recent rate 69.9/sec, hit ratio 0%
...
[15/Apr/2015:17:08:39 +0200] - import userRoot: Import complete. Processed 1539 entries in 126 seconds. (12.21 entries/sec) [15/Apr/2015:17:08:39 +0200] NSMMReplicationPlugin - multimaster_be_state_change: replica dc=lix,dc=polytechnique,dc=fr is coming online; enabling replication

So it would appear that initialization finished successfully. But then . . .


    [15/Apr/2015:17:41:25 +0200] NSMMReplicationPlugin -
    agmt="cn=meToipa1.example.com <http://meToipa1.example.com>"
    (ipa1:389): Unable to receive the response for a startReplication
    extended operation to consumer (Can't contact LDAP server). Will
    retry later.


[15/Apr/2015:17:41:16 +0200] - slapd shutting down - freed 1 work q stack objects - freed 2 op stack objects
[15/Apr/2015:17:41:16 +0200] - slapd stopped.

So the server is down. Did someone or some process shutdown the replica at this time?

    [15/Apr/2015:17:41:29 +0200] slapi_ldap_bind - Error: could not
    send startTLS request: error -1 (Can't contact LDAP server) errno
    107 (Transport endpoint is not connected)

    Any hints will be useful.

    Thanks.





    --
    Manage your subscription for the Freeipa-users mailing list:
    https://www.redhat.com/mailman/listinfo/freeipa-users
    Go to http://freeipa.org for more info on the project



-- 
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to