On Thu, 02 Jul 2015, David Fox wrote:
self._pipe.DeleteTrustedDomain(self._policy_handle, res.info_ex.sid) [Tue Jun 30 13:17:01.369330 2015] [:error] [pid 1063] TypeError: default/librpc/gen_ndr/py_lsa.c:9436: Expected type 'security.dom_sid' for 'py_dom_sid' of type 'NoneType' [Tue Jun 30 13:17:01.369648 2015] [:error] [pid 1063] ipa: INFO: [jsonserver_session] admin@IPA.*redacted*: trust_add(u'*redacted*', trust_type=u'ad', realm_admin=u'*redacted*', realm_passwd=u'********', all=False, raw=False, version=u'2.112'): TypeError


These are whole logs with "log level = 100" set in smb.conf.empty. Log files were emptied before the above command was ran. If there is any other information required please let me know.

Software versions:
Fedora 22: 4.1.4
Fedora 22: 4.2 Alpha 1

Oracle Linux 7.1 64bit: without DNS
ipa-server.x86_64 - 4.1.0-18.0.1-el17_1.3
ipa-server-trust-ad.x86_64 - 4.1.0-18.0.1-el17_1.3

CentOS 7.1 64bit: With DNS
ipa-server.x86_64 - 4.1.0-18-el7.centos.3
ipa-server-trust-ad.x86_64 - 4.1.0-18-el7.centos.3
It is unclear from your report what exact distro causing this issue for
you. Is this with Fedora 22 (e.g. Samba 4.2)?

This error isn't limited to just one distro. I've tried three different distros which all throw the same error as above.
Then it means Samba - Windows interoperability issue. I need:
- network trace between IPA server and your AD DC for all relevant
  ports
- unredacted error_log like above
- Samba logs with log level 100 (net conf setparm global 'log level' 100)

Sent them to me privately.


--
/ Alexander Bokovoy

--
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to