Nguyen, Alicia wrote:
Hi,

I'm having an issue re-adding a client to freeipa (same hostname). When I removed the 
client from the domain I uninstalled freeipa on the client (using ipa-client-install 
--uninstall), removed the keytab, and ran ipa host-del FQDN on the the freeipa master. 
Everything has been rebooted. I cannot re-add the client to the domain (running 
ipa-client-install) and receive this error : "Joining realm failed. RPC failed @ 
server. Hostname already exists."

If I look in the UI I see the hostname under hosts, but it does not show the 
host as enrolled and throws an error that the host doesn't exist.
Running ipa host-find FQDN shows 1 host matched.
Running ipa host-show FQDN says the hosts doesn't exist.
If I run ipa del-host FQDN I receive an error that the host was not found.
If I run ipa host-add FQDN I receive an error that the host already exists.

Please Advise, I'm wondering if there is some record in LDAP that is maybe 
causing this problem.

Sounds like you have a replication conflict entry for this host. See https://access.redhat.com/documentation/en-US/Red_Hat_Directory_Server/8.2/html/Administration_Guide/Managing_Replication-Solving_Common_Replication_Conflicts.html

rob

--
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to