Hi all,

Just did a fresh install of FreeRADIUS following this guide on a
Centos 7 box - 
http://www.freeipa.org/page/Using_FreeIPA_and_FreeRadius_as_a_RADIUS_based_software_token_OTP_system_with_CentOS/RedHat_7

Local testing with radtest works, however radiusd have issues.  I do
find it odd that these line indicated success:

Process: 1270 ExecStartPre=/bin/chown -R radiusd.radiusd
/var/run/radiusd (code=exited, status=0/SUCCESS)

But then:

[root@ipa1test ~]# systemctl status radiusd.service -l
‚óŹ radiusd.service - FreeRADIUS high performance RADIUS server.
   Loaded: loaded (/usr/lib/systemd/system/radiusd.service; enabled;
vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2016-01-05 18:32:09 EST; 15h ago
  Process: 1334 ExecStartPre=/usr/sbin/radiusd -C (code=exited,
status=1/FAILURE)
  Process: 1270 ExecStartPre=/bin/chown -R radiusd.radiusd
/var/run/radiusd (code=exited, status=0/SUCCESS)

Jan 05 18:32:07 ipa1test.lab.net systemd[1]: Starting FreeRADIUS high
performance RADIUS server....
Jan 05 18:32:09 ipa1test.lab.net systemd[1]: radiusd.service: control
process exited, code=exited status=1
Jan 05 18:32:09 ipa1test.lab.net systemd[1]: Failed to start
FreeRADIUS high performance RADIUS server..
Jan 05 18:32:09 ipa1test.lab.net systemd[1]: Unit radiusd.service
entered failed state.
Jan 05 18:32:09 ipa1test.lab.net systemd[1]: radiusd.service failed.

I find a few google hits but they had different error codes & issues
which seemed different. Anyone have any suggestion or should I just go
to latest stable which is 3.0.10?

[root@ipa1test ~]# radiusd -v
radiusd: FreeRADIUS Version 3.0.4, for host x86_64-redhat-linux-gnu,
built on Mar  5 2015 at 23:41:36

Thanks, Anthony

-- 
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to