On 05/02/2016 02:05 AM, siology.io wrote:
> That plugins.py file does exist, but it's totally empty.

Following should be the content of the file. Adding it there should fix
the issue.

https://git.fedorahosted.org/cgit/freeipa.git/tree/install/wsgi/plugins.py

Question how it got into the state. What IPA version from what
repository do you use? Have you done any manual changes there?

> 
> And yes, all i get on the browser is an empty white screen window,

That is most-likely a result of the above.

> 
> On 30 April 2016 at 02:20, Petr Vobornik <pvobo...@redhat.com 
> <mailto:pvobo...@redhat.com>> wrote:
> 
>     On 04/29/2016 12:44 AM, siology.io <http://siology.io> wrote:
>     > On a clean centos 7 VM, after installation of ipa-server browsing to 
> the ipa web
>     > UI gets me in the httpd error_logs:
>     >
>     > [Thu Apr 28 18:41:11.826134 2016] [:error] [pid 10162] 
> [remote10.0.4.10:244 <http://10.0.4.10:244>
>      > <http://10.0.4.10:244>] mod_wsgi (pid=10162): Target WSGI script
>     > '/usr/share/ipa/wsgi/plugins.py' does not contain WSGI application 
> 'application'.
>     >
>     > Is this a known issue ? I didn't get much out of google.
>     >
> 
>     I don't see this issue on RHEL 7.2 nor FreeIPA 4.3.x on F23. Could you
>     paste here content of your /usr/share/ipa/wsgi/plugins.py file?
> 
>     Does it prevent to load Web UI?
>     --
>     Petr Vobornik
> 
> 


-- 
Petr Vobornik

-- 
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to