On 7/12/2016 12:17 PM, bahan w wrote:
Hello everyone.

I'm using ipa 3.0.0-47 on a RHEL6.6 OS (multi-masters).

Today I tried to restart the IPA service with the commande
###
service ipa restart
###

And I got the following warning concerning the pkica service :
###
Since the file '/var/lib/pki-ca/conf/CS.cfg.bak.saved' exists, a
previous backup attempt has failed!  Backups will be discontinued until
this issue has been resolved!
###

And then the service get KO.

I wanted to know, may you tell me when this file CS.cfg.bak.saved is
created ?
Also, do you know why the presence of this file prevent the ipa service
to start ?

Thank you in advance for your help.

BR.

Bahan


Hi Bahan,

To my understanding during CS.cfg backup process the old CS.cfg.bak is temporarily saved into the CS.cfg.bak.saved. When the backup is complete the CS.cfg.bak.saved should be removed automatically.

In your case there might be something wrong in the CS.cfg that causes the backup to fail. Try comparing the CS.cfg with CS.cfg.bak.saved to see what has changed recently. If you find something wrong, shutdown the server, fix the CS.cfg, move CS.cfg.bak.saved somewhere else, then restart the server again.

Please also check if the disk is full.

If it's still not working please send the CA debug log (/var/log/pki-ca/debug) to pki-users mailing list or to RHEL support channel. Thanks.

--
Endi S. Dewata

--
Manage your subscription for the Freeipa-users mailing list:
https://www.redhat.com/mailman/listinfo/freeipa-users
Go to http://freeipa.org for more info on the project

Reply via email to